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Wi JEE azfianusnansafinsaunquiudug s uatdswelugiuly Selimansitaslddiu
idosiiolunmsdnnadwmiugBudu daiulumivisiandiedaniu JSE andszneumaFeuiiionan S
FavihmnfnsvasiTussuurouivasldonuled Tnegatesoefiolumswannaaziunii Java Development
Kit (JDK) wazifiuduusniiindosinavasly sodunauselii

1. @ansaeniilvan JDK 1(31'171' Gulad http://www.oracle.com/technetwork/java/javase/downloads/

laeidansu Standard Edition (JSE) wazidansilawdfnasldnseiussuudjuinmsininldnuey
ﬁ\ana’%‘ﬁ’umqﬂimmzﬁLﬁﬂuwﬁf\iﬁa \anilAa Java 9 (JDK 9)

2. emnmnilnanaSalvisudiananilildanne wassniuiaaniju Next [iSoe sundinsguauns

WIEFIRY s undsnIRaieEmUIZULIWIRdows NN AREBETING:\Program Files\Java\
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wiIMIfase wnazldmuunnzevmideasi flisndudavaamlar sz bildnusu
JOK Toeas wiedldsiulusunsadszinn IDE unu siliilavan JOK Sulsidl Editor fwsuideuldauly
o503l FlUsunInwan Text Editor 1 Notepad Tumadeuldn win1sdesusneg fdpeluifauras
WY Command Line 391uismafigeennauiiuly daiulumivie iuiieasidouldnuaznaaoumavinnu
gy MHulUSuNINUIEIAN IDE (Integrated Development Environment) iwanzfia3aaianasitamn
Widustasuaiu Tapaznhausuuimensld IDE Sy 2 i fleaduuazldSuanaiougegalu
ilaq1iufie NetBeans uay Intelli Sogeuazidanldenlafild dmiAsnsfadouazuumemsldou IDE
wianiluiieedu asnandedases v

1-5: msdiaco NetBears

NetBeans \uldsunsudszim IDE Afigldoududauiuann Segaisusey NetBeans favilds

LY)

v '
' = =

o pFaviiasieg Adunsunsldnuiihe lelifidnsusigeennviadudou

o fimsavdadwiuiminuaUnwiiadusiaananiieevasudiu

o Iisumamivayulnenanidizesnsfusdgn Sun Microsystems 31aufly Oracle Auiludv
F3zAuAnNEaiianInnIn
& a v o P~ . P o o

o Hulvsunsnfiuanlitldns Towlifigu Commercial wiflouiy IDE 1196

o upnmnazlFi@auannuan deaansalddoulusunsuyszinnidu wu PHP, HTML w3adueq (&

gnaae

o winzat WA mILEINAY viagfidamsniudnmardunan
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#1921 NetBeans anifutazaviialunsifauan fdaviinse JOK sefildnananlurdadfiug,
fiow MavNtuivAsEAnAY NetBeans duitunaulasdvivavsialuil

1. @nsaaiilvan NetBeans [sani5ulss https:/netbeans.org/downloads/

SE-ED
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o

2. M3fnAY NetBeans Hhwilaudulusunsuiig (U lnedefidasmvualuunsiunauiisedl

1-6: Msaswolusidncidos NetBeans

mMsdpuasnelusunsudszan IDE Bidlafina asdoeEuinsa’elusidnd (Project) Tuy

wap Sufidpusdnaedustnlaatnmiluiues louliidadng NetBeans uawvihmudunsussisludl

1. \@enfiy File » New Project v3aaaniilonau ] uuyains

2. Tumihaednly Sdarviuasilae
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A392iBY Categories WiAan Java (Favmsi@oulysunsusiansan)

A39%89 Projects 1Widan Java Application (fiavnmsaaiduuatwiiadiy)

o

3. Tudumauinly Adofwuaiinmsiidufindeilde

Project Name #adialis19nd @9muUnA NetBeans avmviiniilu JavaApplicationX a1
v o A o = a @ & Y v ¥ o °
Taramh (X Fesuar) dumanssaasududalvalldmunsens wagdnihwvaigg M
i WidsusnessdudmmasusarAdusmailna 19U MyFirstApp, JavaExample,
TestOfNetBeans L{udu

Project Location Aasuvitismsdnifulusidng Seanuni NetBeans azifiu[3# C:\Users\

f"iaQ‘[‘ﬁ\Documents\NetBeansProjects\

wiltsnazwasulifuBasiwmisduld waial¥iduwuimeiieadu fidsunusirinadsld

LY

FLNLNAINT NetBeans mviuann lwHiazfingn

Project Folder Aasuniviiazdinlnainasnaziivlndsiie vaslusidnd lnainlidaelaen
avly zauUnAnan NetBeans azadlnawmadmudalusiinanisnmviuailaudnlusii@
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Use Dedicated ... Tuidavsiu faldsndudaslddiaani

Create Main Class Jumsmviuadn #9n13a319 Main Class uifupanasuwsniums

vvuzeeladng deludevdiuil fiflsununhliidaiidadent wasdviidowhmugiude

masedanans laeddamuuuimesey NetBeans aldguuuy
HouwaLna.Aanana
~ & vd o o & ¢ A & v oA & O
Fauwiang Wldsefentutalusind wa@audusRuwiLdnionye

Fonara Taviee uaziihuansg mansniu Widsusnassiuduaasudazmduffun
Tna) wu susfnegialusiindidu FirstApplication uasfiaenmsivinanadis AppMain
fitvunanavlutaviliiiu firstapplication.AppMain LTy

pevl5Aimuy Tutey Create MainClass L318anNA \Ney wAdBARIaaY L p el Toe

listperimuagouiiainafild (19 Default Package) i fdpsnstiaaadio AppMain fiszy

v
=1

wadatiagly senw

4. FuNfTNNTuRURMUIN e lUsEndu FirstApplication wazivusdaraaidiu AppMain

Wamdnly Finish fiazidhgrthaenanzey NetBeans Fulansuzavil
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De
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o

uananilgefinadituguieiulus@ndiinasiiagn Gl

1%

o ddavniseananluaing azuuniansuniu 2 nsdife

v

"davmasenannlusi@nswieniila Netbeans Tidonfiuy File » Exit

s ¥ o v

fdpvmaiievualialysiand udanauiingnthas Sasiuaey NetBeans Tildianiiwy File >

'
a '

1tang)

U

Close Project (Zaly5\8neii

o Wamndadhglusunan NetBeans) asvsslisutnfiasfihedelus Sndmnaivienoglu
3ule§ Projects mitvinedie dlivsingiuladil Wilanfiuy Window » Projects
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o Mlusdndimnezdalivaingeyluiulad Project Alidaniiy File » Open Project

o wnmazdpuldnan fdevidalwdvavaaamudeiildivunie Baousivlusdnd Toelud
3uln§ Projects udzenalvun dalusidnsd » Source Packages » dauwaina solusuida
AANT [WsnavAas awnﬁuLLﬁumaoTﬁmazgnLﬂm%u @ hildmvunuiananauailusidng Wa
yavaaas1vazatlulwainas default package)

o nndavmsavusslAsutianata fivingeiiAa

msaupana- WRanaNdeaa aiuiulad

@

Delete s
O

. Projects uaaldan Delete Liinfllnazdnndiu
Delete AppMain

Safely delete (with usage searchk N’ﬂﬁLﬁﬂ ﬂﬂ'ﬂﬂ%’u ﬁﬂ’;ilﬁﬂv‘}ﬂé’u Lﬁ Eﬁﬁﬂ |

Search In Comments Qﬂﬂﬂﬂﬂ’]\iﬂugiﬂj
Preview Cancel Help . . . .
mMswasudsnand awldsuilenlaanse
© Rename Class AppMain X welalld sfishuiiifeadeednvans uwedi
New Name: [Mainapp Swdedoamaiinldaieiu Ineisiignaes

| & ¥ a ad v oo
EA Apply Rename on Comments Ao Tadnanfdamanawadidan Refactor

oreven — — > Rename uasuse fideivaanalude

Winazgnilasududelualadnludd
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v v & oo v X ] ' a < . ) v a_ da & _ <& v
® ﬂ']ﬂﬂ\'m'ﬁﬂﬂ‘[ﬂitﬁﬂmﬂﬂ?]\ﬁmu mﬂﬂi’mgﬁﬂﬂgumﬂm Projects ﬂI‘iﬂﬂaﬂV}‘ﬁaIﬂiLQﬂmuuLLﬂ'}ﬂﬂ

a e ¢ o a v oo v & A A & & v o
Aduasaila Delete WipazAdnpIUAIEaN Delete Alel MnilwidodlnazdanTusnlidudu as
G oo oo v = & _ o ' 3
\fnfisaldan Also delete sources under ... M WplAlUsEnAgnavatvanysal

O Delete Project

—
'-Q-' This will delete project "FirstApplication” so that it cannot be opened in the NetBeans IDE anymore.

Are you sure you want to delete it?

# Also delete sources under "C:\Users\User\Documents\NetBeansProjects\FirstApplication” folder.

o uwimlysdndAiindesmsaulidnngluiulad Project fimadadrlugdesumieiiinifiv
Tsiindaay NetBeans tonld Fomnnldmuednaasdazagf CaUsers\Baglé\Douments\Net-

BeansProjects\ MniiuaulwatnasvaslusiindiunelUifiae

1-7: msmnuawoudia sy NetBeans

anwauzwaudlunsuanlAnTINTINTLaAIHas ST NetBeans imuas v o19azlignlaiamin wu
waavdnaszaen nlidessvn viefimnedilined wiasgdatunuAuluilviewldnann s g

aNIaUSuwasuWaud v [dsanumesa U

1. \®Aanflluy Tools » Options

2. Tumhaedaly Tdanmuaidunaneaalunwas
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1) Fonts & Colors 4) Category: Default
2) iy Syntax 5) Font: AANUW ...
3) Language: All Language

3. niuazUnngleesfenTumnldiadensiia Uuuy uazsnezesweudndons laumsidensia
Movsummnineuasbianuiuly dwsulunsdvesfifouldifonsiin Leelawadee 1110 14 a9
m3iden Wiadnly Apply Walinawsignui [uld

@J Font Choosef s

Font: Font Style: Size:

Leclawadee | |Blairg 14

Kristen ITC ~
Kunstler Script Bold

Leelawadee UI Bold Italic

5
3
10
12
Leelawades UI Semilight
Letter Gothic Std 18
24
35
43

Preview

The guick brown fox jumps over the lazy dog

Inherited Cancel
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4. davmsUSuudvwaudAuey Output (Fruuanvnaaniuiaraulea) TadnmuadUNLLEY
Tunmwdaly udndsnweusdnnlaezdonmiowds swsulunsdivesdBeulfifonyiln Leelawadee
IUIN 14

1) Miscellaneous 3) AAnLw ...

2) i) Output

sansanaasvgansusasswaudfidenludesduld Iasdsudldadunwinll usnaddueia
Un F6 iasulusunsn gimeudfidanantugnlasviali thlsigevfinaulyioniv

Projects X | - @ AppMain. java X|
=& Frstappicaton souce | Ao, (5= el < R 3 | P )| i 2 o o [ s
- ljg Source Packages P
&[] frstappiication ; package firstapplication;
i @ AppMain.java . -
(B Libraries 2 public class AppMain {
5 public static void main(5tring[] args) {
8
7 Sys‘tem.out.println{"a-mﬁaumil.:ﬁmiﬂj‘am'n;J.nT;Jﬁ"'ﬁ,-1sJ"),' ‘_
8
9 }
10
11 1
12
: Qutput - FirstApplication (run)
BB | run:
[ | wmeaumsea AiaATRAE e ‘_
BUILD SUCCESSFUL (total time: 0 seconds)
|~ |

o
a o

drumstsuusslunsaldug azhannanadusslUSesg Twihdefiiieadas
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¥ BNEG

NetBeans 199:dilymiunausiinguveida narade navaniisnudennousiase lonaungi Code

Editor a19vsuanvwalagnday usidelalusunssn NetBeans uaudaduxilvs anwasvovnouson

amweuly soiuwaliuilerwausdiisudanainisaltviulsesy vavernidamassudalitnltsunsn
v o & Iy = ¥ A a

NetBeans ududaduslva deusitymsbivasuiiusinduunu

1-8: msaad® Intelli) IDEA

IntelliJ IDEA {iuldsunsnyszinm IDE susunmsi@euldaaniimasldsuanuianatasinaintin

WelLseaufiaondn wszlansusieuraisyszns 1oy

o fsusewhmiiaisns ihldnunnnd

o fwmaflanmavhoulunane nsdifizngaaianit IDE fduq

o fjuiuanlfldommsuunlisiouls

o 1 IDE fignihlummnifu Android Studio hwsunsaivusUULAUATEEE AUNLFIIAING

agnduiugfisAnsanieiillgmadsuuesdusunsaudliuauan

LY

FirstApplication - [C:\Users\User\IdeaProjects\FirstAp,
File Edit View MNavigate Code Analyze Refactor T Window Hel
= H O ¢ Dol QAR |« h
. FirstApplication ' " src * € AppMain '

G 3] Project v @ = | - |- | € AppMain java m
2|v IgFi lication C:\Users\User\ldea i v =
E v NaFther T Teeica@piration starts here 3
] 2 2, g
‘= > [ out 3k public static void main(String[] args) { | g
~ src 4 System.out.println("Hello World"); 2
o _ - " . m, -
E e AppMain 5 System.out.printin( VRADUT DA IHATE e");
z 'y FirstApplication.iml £ 1 ¥
|3 ||l External Libraries ) ;
v 8 H =
9
g
o)
* AppMain ¢ main()

Q Event Log

= 0: Messages Terminal P 4: Run % & TODO
247 CRLF: UTF-8: & &

[ Compilation completed successfully in 4s 606ms (a minute aga)
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fusmanh Intellid sufuasaviielunmsdouan ffeefinse Java (JDK) suiilénanisnluida
Aoy i ndvaniuIsAssRnm Intellid Fufidunaulnedodssa Uil

1. @nsaanilvan Intellid [daniulsd https://www.jetbrains.com/idea/download lagvinn
favmsldnunafliiaangu Community Edition

@

2. M3Aand Intellid Avihmdaunulysunsumg (U Tnedaimualuunsiiunausioeil
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1-9: Wupumsigaumondos Intelli) IDEA

m3dauaniin Intelid azfpvianimaainlusing (Project) Twsitawe lawliilaudg Inteliiy

wavaNNTUnaUIFa U

1. Lﬁaﬂmngwﬁwa Welcome to IntelliJ IDEA Lﬁanﬁmg Create New Project

2. Fusndivezduld Intelli Wu@densn wasssmldtmuasumiviinas Java (JDK) anl3 Ak
Wesiiae
1) &8an Java
2) adntu New ...
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3) BansuriefitnAnne JDK 3 @avidanlwaines jok laild jre)

4) shumdefilaidon szandngluges Project SDK

M3EaFuLy JDK 1 asrinanzidoaavlysisnsun Intellid suasousniyiniy uda
asosiog U i lidovisaaidsn iwnslusunsnesenssiumivi 3 lnesnlusis
SNTUNATY 1TNYRBUIIMIUYTARGY JDK [y vsasiinsmiiuiastulva
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3. manUn Next sialUauiiviunsunmssvdalusing Aldimuadomudovns (dwanmadieniu

(%4

NetBeans) aausuvitinsanuiulysiang wusihlildeanaasiony IntelliJ Ao C:\Users\%a

cl°i‘f\|deaProjects\

Wadhglusunay Intellid feslanwouszevil

ovan Intelid Taldadommasntimarmh dofudefidgashas maduasalvsidghn
Tulusidnd Taeidulad Project (mnliunngliadnasuiivdudnemednedie viaidanan
Y View » Tool Windows > Project) ﬂﬁﬂ%ﬂﬂﬂiﬁuﬂ%ﬂiﬂilﬁﬂﬁ (ﬂ‘iﬂi"ﬂa\‘lﬂ'@ﬂuﬁ'\‘l%a v
FirstApplication) mnﬁuﬂﬁnmwﬁ Watnas src » New » Java Class Ltﬁaﬁ’muﬁ‘ﬁaﬂmﬂ
avlt Tnelgmanmaieanuiiasnelu NetBeans wazlugos Kind fiavidensiindiu Class fae



unf 11 mm9mazinrasialunindaulam 39

Indwasamnaazgnaiululwainas src Fomninduidandndlwddonan Aazsnguii

aasl@ndil

tdovmslalusidnd THilanfiuy File » Close Project dvfiasnauidhgniih Welcome

usidhdavnslanvlusidnduazdl Intelid se THidoniiay File > Exit

Wan@edhg intellid luasvsaly axlsnngaadellaindnsuauasvioindosudieie

vponthan Welcomewsit difimedatannng luzesillvinaniliany Open udidonsuvtefiin
Foufiulusdndionld deildmainaasiauiinananfide C\Users\Hag[#\IdeaProjects\
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v = = o &9 vo o N
® VINNABNNTALWIBLUABUBRARNE fﬂ,‘ﬂ‘ﬂqﬂ\‘iu B

© nsauAaNs AAnTINNTanaanslnalaas src wdlldan Delete wiadllnazianduan

Widsneeudu wusnhideynduieliaanagnavstvanysal

Delete

Delete class "AppMain"?
Safe delete (with usage search)

Search in comments and strings

Search for text occurrences

Cancel

o mswasutapana azwdsunldnlaunseaslila wszidunifeddeednvanewvii

shedvBeamafinldaieiiu lneisngnsiasde Iadnzniidoamanslnaines src uan

\i8n » Refactor » Rename lnguuzihldi@annesyduiieiaiuse idwivaaalu
Fopn gnuasududelnilasdnluds

Rename

Rename class 'AppMain’ and its usages to:

|MainApp

e

Search in comments and strings Search for text occurrences
Rename variables

Rename tests

Renarme inheritors

0 | Refactor | | Preview P Cancel |

o tdpemsaulusidng liaansaauru Intellid: I8 dawilan luUfedwmisiimndaifiulysina

101[37e C:\Users\THagldi\IdeaProjects\ Laraulwainaizavlisiindiumiounulnanes

mly
IdeaProjects - O *
<« - 4 C:\Users\ User\|deaProjects w | @ Search |deaProjects 0@
~ . A
3 Quick access FirstApplication
[ Desktop
f@ OneDrive
8 User
= My Computer
v
Titern 1 itemn selected =z =
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1-10: msmnuawoudarksu Intelli) IDEA

NoudzaslAnuazdrunadwsi Intelid fvuamniiaronth onadadumlumsuaasnsning vi3e
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fisUuvuiilidosgnlatin Sefmansnwasuwasyaile ol

1. \@enfiy File » Settings...
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o o
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\don?i Editor » Font
LEANSY Show only monospaced fonts 28N

Wenailawsuduazimuasnamusionis lovlunsdizesdideu [Fidensiin Leelawadee

210 14
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s o

3. ddavnismuuanausadalln Console (LEAYNAANS) Hdunauay

D¢

\dan Editor » Color’"Scheme » Console Font
1 EARTY Show only monospaced fonts 880

densfianauduazivunasuianinsosnds Taglunsdvsed eudonsila Leelawadee
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aEnsanaFauMIwaasnauddanan laefvualdaselumwdaly wih
m3fulsunsnassusniiiieniiay Run > Run... 9ntiuidands Main Class (lu

fitifia AppMain) uslumssuasesiaq [Wadndilanau ») vuyansldian
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