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ค�ำน�ำ

D	ata Science ถือเป็นวทิยาศาสตร์อกีแขนงหนึง่ทีว่่าด้วยการวเิคราะห์และจดัการข้อมูลในรปูแบบต่างๆ  

แล้วยังเป็นพื้นฐานไปสู่การเรียนรู้เทคโนโลยีแขนงอื่นๆ อีกหลายอย่าง ไม่ว่าจะเป็น Data Mining, Deep 

Learning, Machine Learning และ Artificial Intelligence (AI) นอกจากนี้ยังสามารถน�ำ Data Science  

ไปประยกุต์ใช้กบังานหลายๆ ด้าน เช่น ไอท ีอตุสาหกรรม และโดยเฉพาะอย่างยิง่ทางด้านธรุกจิ กไ็ด้น�ำ Data Science  

มาเป็นเครื่องมือส�ำหรับการวิเคราะห์ข้อมูลต่างๆ กันอย่างแพร่หลาย เพื่อสร้างโอกาสและความได้เปรียบในการ

แข่งขัน และด้วยเหตุผลดังที่กล่าวมา ในปัจจุบันจึงมีผู้สนใจการเรียนรู้เกี่ยวกับ Data Science เป็นจ�ำนวนมาก

อย่างไรก็ตาม ทางเลอืกส�ำหรบัการศกึษา Data Science นัน้มีหลายแนวทาง เช่น การใช้เครื่องมือส�ำเรจ็รปู 

หรือการเขียนโค้ดด้วยภาษาคอมพิวเตอร์ เป็นต้น แต่แหล่งข้อมูลเกี่ยวกับ Data Science ที่เป็นภาษาไทย 

ยงัมค่ีอนข้างน้อย ดงันัน้ ผูเ้ขยีนจงึได้จดัท�ำหนงัสอืเล่มนีข้ึน้มา เพื่อใช้ประกอบการเรยีนรูเ้กีย่วกบั Data Science  

โดยใช้ภาษา Python ร่วมกับไลบรารีต่างๆ เช่น NumPy, Pandas, Matplotlib และ Scikit-learn ซึ่งนอกจาก 

Data Science แล้ว ก็ยังมกีล่าวถึง Machine Learning ขัน้พืน้ฐานเอาไว้ด้วย เพื่อให้ผูอ่้านสามารถน�ำไปจดัการ

และวิเคราะห์ข้อมูลในเบื้องต้นได้ รวมทั้งเป็นแนวทางส�ำหรับการเรียนรู้เพิ่มเติมในระดับที่สูงขึ้นต่อไป

บัญชา  ปะสีละเตสัง 
banchar_pa@yahoo.com

facebook.com/DeveloperThai
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ในการใช้งานเกี่ยวกับ Data Science หากเราเขียนโค้ดด้วยองค์ประกอบเท่าที่มีในภาษาไพธอนโดยตรง 

ก็จะยุ่งยากจนเกินไป ซึ่งวิธีที่สะดวกกว่าคือ ใช้งานผ่านไลบรารีต่างๆ เช่น NumPy, Pandas และ MatPlotLib 

เป็นต้น  โดยในบทนี ้เราจะเริม่ต้นด้วยการตดิตัง้ส่ิงทีจ่�ำเป็นส�ำหรับการศึกษาเกีย่วกบั Data Science และเรียนรู้ 

วิธีการเขียนโค้ดด้วย Jupyter Notebook เพราะสะดวกกว่าการเขียนด้วยโปรแกรม IDE อื่นๆ เพื่อเป็นพื้นฐาน

ส�ำหรับการใช้งานในบทต่อๆ ไป

การติดตั้ง Anaconda
Anaconda เป็นชุดแพ็คเกจส�ำหรับการติดตั้งเครื่องมือและไลบรารีของภาษาไพธอน โดยเน้นเกี่ยวกับ 

Data Science เป็นหลัก ทั้งนี้เนื่องจากไลบรารีแต่ละอัน จะถูกสร้างขึ้นด้วยวัตถุประสงค์ที่แตกต่างกัน ดังนั้น 

การที่เราจะศึกษาเกี่ยวกับ Data Science ได้อย่างสมบูรณ์ ก็ต้องติดตั้งไลบรารีเหล่านั้นให้ครบทั้งหมด แต่เพื่อ

ลดความยุ่งยากดังกล่าว เราก็สามารถติดตั้งไลบรารีเหล่านั้นผ่านแพ็คเกจ Anaconda แทน ซึ่งประกอบด้วย

เครื่องมือและไลบรารีปลีกย่อยมากมาย เช่น Jupyter, NumPy, Pandas, MatPlotLib, Seaborn เป็นต้น โดย

แนวทางการติดตั้งคือ

1.	 ดาวน์โหลดไฟล์ติดตั้งได้ที่ https://www.anaconda.com

2.	 การติดตั้งโดยส่วนใหญ่ เรามักจะใช้ค่าดีฟอลต์ทั้งหมด โดยขั้นตอนที่ส�ำคัญมีดังภาพต่อไปนี้

การใช้ Jupyter และ Colab 1
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เมื่อเราติดตั้ง Anaconda นอกจากไลบรารีต่างๆ แล้ว ตัวแปลภาษาไพธอนก็จะถูกติดตั้งลงไปด้วย และ

เป็นส่วนหนึ่งของ Anaconda โดยไม่ขึ้นอยู่กับชุดติดตั้งของภาษาไพธอนตามปกติ (ใช้งานผ่าน Python IDLE) 

ดังนั้น จึงสามารถเขียนโค้ดไพธอนและทดสอบการท�ำงานผ่านชุดเครื่องมือของ Anaconda ได้ทันที ตามที่จะ

กล่าวถึงในหัวข้อต่อๆ ไป

ลักษณะของ Jupyter Notebook
Jupyter Notebook (หรอืชื่อเดิมคือ IPython Notebook) เป็น

หนึ่งในชุดเครื่องมือที่ถูกติดตั้งพร้อมกับ Anaconda ซึ่งใช้ส�ำหรับการ

เขียนโค้ดไพธอน ด้วยรูปแบบของ Web Application และจะท�ำงาน

ร่วมกับ Server บนเครื่องของเราเอง ส�ำหรับแนวทางการใช้ Jupyter 

ที่ควรรู้จักในเบื้องต้นมีดังต่อไปนี้

การเข้าสู ่Jupyter ส�ำหรบัระบบ Windows ให้เร่ิมจากเมน ูStart  

แล้วเลือกเมนู Jupyter Notebook จากกลุ่มโฟลเดอร์ Anconda3 

ดังภาพ และหากต้องการความสะดวกส�ำหรับการเรียกใช้งานใน

คราวต่อๆ ไป ก็อาจลากเมนูดังกล่าวนี้ไปวางบน Desktop เพื่อสร้าง 

Shortcut ก็ได้

หลังจากเลือกเมนูดังกล่าว จะมีวินโดว์ Jupyter Notebook Server ปรากฏขึ้น (โปรแกรม Anti-Virus 

บางตัว อาจบล็อกการท�ำงานของไฟล์ Server ดังนั้น เราต้องยกเลิกการตรวจสอบไฟล์ดังกล่าว)
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เมื่อวินโดว์ Jupyter Notebook Sever ปรากฏขึ้นมาแล้ว หลังจากนั้นอีกสักครู่ เว็บเบราเซอร์ตัวที่เรา

ตั้งค่าเป็นดีฟอลต์ไว้ในระบบ จะถูกเปิดขึ้นมาพร้อมกับเข้าสู่หน้าจอ Home Page ของ Jupyter หรือเรียกว่า 

Dashboard โดยอัตโนมัติ ดังภาพถัดไป (หากต้องการเปิดด้วยเบราเซอร์ตัวอื่น ต้องแก้ไขการตั้งค่า Default 

Browser ของระบบ)

ในระหว่างที่เราใช้งาน Jupyter Notebook ห้ามปิดวินโดว์ Server จนกว่าจะเลิกใช้งาน Jupyter  

มิฉะนั้นการเชื่อมต่อจะสิ้นสุดลง ส่งผลให้เราไม่สามารถรันทดสอบโค้ดได้

การเขียนโค้ดไพธอนและรันทดสอบ
หากเราต้องการเข้าสูข่ัน้ตอนการเขยีนโค้ดไพธอนบน Jupyter Notebook ให้คลกิทีปุ่ม่ New > Python 3  

ดังภาพ
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หลังจากนั้น เราก็สามารถเขียนโค้ดของภาษาไพธอนลงในช่องเซลล์ และหากต้องการรันทดสอบ ก็ให้

คลิกที่ปุ่ม Run หรือกดปุ่ม <Shift + Enter> 

ส�ำหรับ Jupyter Notebook จะแบ่งกรอบในการเขียนโค้ดออกเป็นช่องๆ และเรียกแต่ละช่องว่าเซลล์ 

(Cell) ซึง่เราสามารถรนัเพื่อดผูลลพัธ์ของโค้ดในเซลล์ใดเซลล์หนึง่ได้เลย โดยคลกิทีเ่ซลล์เป้าหมาย (มีเส้นกรอบ

สีเขียวล้อมรอบ) แล้วคลิกปุ่มรัน หรือกด <Shift + Enter>

ส�ำหรับการรันโค้ดในแต่ละเซลล์ นอกจากการคลิกที่ไอคอน Run แล้ว ยังมีทางเลือกอื่นๆ โดยการกดปุ่ม

คีย์บอร์ด หรือเลือกจากเมนู ดังต่อไปนี้
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•• <Alt + Enter> เพื่อรันเซลล์ที่ถูกเลือกในขณะนั้น แล้วสร้างเซลล์ใหม่ ถัดจากเซลล์ที่รัน

•• <Shift + Enter> เพื่อรันเซลล์ที่ถูกเลือกในขณะนั้น แล้วเลือกเซลล์ที่อยู่ถัดจากเซลล์ที่รัน

•• <Ctrl + Enter> > เพื่อรันเซลล์ที่ถูกเลือกในขณะนั้น แต่ไม่สร้างเซลล์ใหม่

•• คลิกที่เมนู Cell ดังภาพถัดไป จากนั้นก็เลือกลักษณะการรันที่ต้องการ

•• หลังการรัน หากต้องการลบผลลัพธ์ออกไป ก็คลิกที่เมนู Cell จากนั้นเลือกอย่างใดอย่างหนึ่งคือ

๏๏ Current Outputs > Clear เพื่อลบผลลัพธ์ของเซลล์ที่ถูกเลือกในขณะนั้น

๏๏ All Output > Clear เพื่อลบผลลัพธ์ของทุกเซลล์
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การจัดการเกี่ยวกับเซลล์
หากเราต้องการจัดการเกี่ยวกับเซลล์ เช่น เพิ่ม ลบ ย้ายต�ำแหน่ง ก็สามารถท�ำได้ด้วยวิธีการต่างๆ ดัง

ต่อไปนี้

•• การเพิ่มเซลล์ใหม่ มีวิธีการให้เลือกคือ

๏๏ รันโดยกด <Shift + Enter> หรือ <Alt + Enter> จะมีเซลล์เพิ่มต่อจากเซลล์ที่รัน

๏๏ คลิกที่ปุ่ม  จะมีเซลล์เพิ่มต่อจากเซลล์ที่เลือกในขณะนั้น

๏๏ เลือกเมนู Insert > Insert Cell Above เพื่อแทรกเซลล์ใหม่ ก่อนเซลล์ที่เลือกในขณะนั้น

๏๏ เลือกเมนู Insert > Insert Cell Below เพื่อแทรกเซลล์ใหม่ ต่อจากเซลล์ที่เลือกในขณะนั้น

•• การลบเซลล์ ก็เลือกเซลล์เป้าหมายที่ต้องการ แล้วคลิกที่เมนูต่อไปนี้

๏๏ Edit > Delete Cells เพื่อลบเซลล์ที่ถูกเลือกในขณะนั้น

๏๏ Edit > Undo Delete Cells เพื่อยกเลิกการลบเซลล์ครั้งล่าสุด
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•• การย้ายต�ำแหน่งเซลล์ ให้เลือกเซลล์เป้าหมาย จากนั้น คลิกที่เมนูอันใดอันหนึ่งคือ

๏๏ Edit > Move Cell Up (หรือคลิกปุ่ม  ) เพื่อเลื่อนขึ้นไปอยู่ข้างบนเซลล์ก่อนนี้

๏๏ Edit > Move Cell Down (หรือคลิกปุ่ม  ) เพื่อเลื่อนลงไปอยู่ข้างล่างเซลล์ถัดไป

•• การแยกเซลล์ หรือผนวกเซลล์ ให้เลือกเซลล์เป้าหมาย แล้วเลือกเมนูอันใดอันหนึ่งคือ 

๏๏ Edit > Split Cells เพื่อแยกเซลล์

๏๏ Edit > Merge Cells Above เพื่อผนวกเซลล์ที่เลือก กับเซลล์ข้างบน

๏๏ Edit > Merge Cells Below เพื่อผนวกเซลล์ที่เลือก กับเซลล์ข้างล่าง
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•• การตัด คัดลอก และวางเซลล์ ให้เลือกเซลล์เป้าหมาย แล้วเลือกเมนูต่อไปนี้

๏๏ Edit > Cut Cells (หรือคลิกปุ่ม  ) เพื่อตัดเซลล์ไปไว้ใน Clipboard

๏๏ Edit > Copy Cells (หรือคลิกปุ่ม  ) เพื่อคัดลอกเซลล์ไปไว้ใน Clipboard

๏๏ Edit > Paste Cells Above เพื่อวางเซลล์ที่ตัดหรือคัดลอก ก่อนเซลล์ที่เลือกในขณะนั้น

๏๏ Edit > Paste Cells Below (หรือคลิกปุ่ม  ) เพื่อวางเซลล์ที่ตัดหรือคัดลอก หลังเซลล์ที่

เลือกในขณะนั้น

๏๏ Edit > Paste & Replace Cells เพื่อวางแทนที่เซลล์ที่เลือกในขณะนั้น

การบันทึกโค้ดและการเปิดไฟล์
โดยปกติแล้ว โค้ดที่เราเขียน จะถูกบันทึกโดยอัตโนมัติในชื่อ UntitledX.ipynb (ส่วนขยายของไฟล์ 

มาจากชื่อเดิมของ Jupyter คือ IPython Notebook แม้จะเปลี่ยนเป็นชื่อ Jupyter แล้ว ก็ยังใช้ส่วนขยายของ

ไฟล์เป็นชื่อเดิม) ทั้งนี้หากเราต้องการเปลี่ยนชื่อไฟล์ ให้คลิกที่ชื่อตรงแถบด้านบน จากนั้นก็ใส่ชื่อที่ต้องการลง

ในไดอะล็อก

1
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2 3

และถ้าต้องการเปลี่ยนชื่อไฟล์ ก็ท�ำเช่นเดียวกับตอนบันทึก คือคลิกที่ชื่อไฟล์ แล้วก�ำหนดชื่อใหม่ตาม 

ขั้นตอนเดิม และหากจะลบไฟล์ ก็อาจเปิดมาที่หน้า Home Page แล้วเลือกไฟล์ที่ต้องการ จากนั้นก็เลื่อนขึ้น

ทางด้านบนและคลิกปุ่มลบ 

1

2

inspiration starts here



23 บทที่ 1  การใช้ Jupyter และ Colab

หากต้องการเปิดไฟล์ของโค้ดที่เคยบันทึกเอาไว้ ก็เปิดมาที่หน้าจอ Home Page หรือไม่ก็เลือกที่เมนู 

File > Open จากนั้น จะปรากฏรายชื่อโฟลเดอร์และไฟล์ให้เราเลือกในแบบลิงก์ ซึ่งหากเราต้องการเปิดไฟล์ใด 

ก็คลิกที่ไฟล์นั้น

ส่วนต�ำแหน่งที่แท้จริงของไฟล์จะขึ้นกับต�ำแหน่งที่เราติดตั้ง Anaconda ซึ่งตามปกติ ส�ำหรับระบบ  

Windows หากเลือกติดตั้งตามค่าดีฟอลต์ก็จะอยู่ที่ 

C:\Users\ชื่อผู้ใช้\

หรือถ้าเราน�ำไฟล์ .ipynb มาจากที่อื่น หากไม่ใช้วิธีการคัดลอกไฟล์ไปวางที่ต�ำแหน่งดังกล่าว ก็อาจใช ้

วธิอีปัโหลด โดยทีห่น้า Home Page ให้คลกิทีปุ่่ม Upload จากนัน้กเ็ลอืกไฟล์ตามต้องการ (เลอืกได้มากกว่า 1 ไฟล์)  

แล้วไฟล์เหล่านั้นจะถูกน�ำไปเก็บที่โฟลเดอร์ C:\Users\ชื่อผู้ใช้\ ให้โดยอัตโนมัติ
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2

1

การใช้ Keyboard Shortcut ในการเขียนโค้ด
ในขณะเขยีนโค้ด เราอาจต้องการใช้ Keyboard Shortcut เข้ามาช่วยส�ำหรบับางกรณี เช่น การเพิม่หรอื

ลดระดับการเยื้องโค้ด หรือแสดง Code Completion หรือการย้ายต�ำแหน่งเคอร์เซอร์ เป็นต้น โดย Keyboard 

Shortcut ส�ำหรับ Edit Mode ที่น่าสนใจของ Jupyter มีดังนี้

<Tab> ใช้ใน 2 กรณีคือ 

•• ถ้าเคอร์เซอร์อยู่ที่จุดเริ่มต้นของบรรทัดจะเป็นการเยื้องโค้ด

•• ถ้าเคอร์เซอร์ตามหลังอักขระอื่นๆ จะเป็นการแสดง Code Completion (ถ้ามี)

<Ctrl + ]> เพิ่มการเยื้องโค้ด 1 ระดับ

<Ctrl - [> ลดการเยื้องโค้ด 1 ระดับ

<Ctrl + A> เลือกโค้ดทุกบรรทัด

<Ctrl + U> ยกเลิกการเลือกโค้ด

<Ctrl + Z> ยกเลิกการกระท�ำล่าสุด (ถ้ากดต่อเนื่องไปเรื่อยๆ ก็จะยกเลิกการกระท�ำก่อนๆ นี้

ตามล�ำดับ)

<Ctrl + Y> ท�ำซ�้ำ (Redo)  ส�ำหรับการกระท�ำที่ถูกยกเลิกก่อนนี้

<Ctrl + /> เพิ่มค�ำอธิบาย (Comment)

<Ctrl + D> ลบบรรทัดที่เคอร์เซอร์ปรากฏอยู่ ทั้งบรรทัด

<Ctrl + Home> เลื่อนเคอร์เซอร์ไปที่จุดเริ่มต้นของเซลล์

<Ctrl + End> เลื่อนเคอร์เซอร์ไปที่ท้ายเซลล์
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<Ctrl + Arrow-Left> เลื่อนเคอร์เซอร์ไปทางซ้าย 1 ค�ำ (word)

<Ctrl + Arrow-Right> เลื่อนเคอร์เซอร์ไปทางขวา 1 ค�ำ (word)

<Ctrl + Backspace> ลบค�ำทางซ้ายของเคอร์เซอร์จ�ำนวน 1 ค�ำ

<Ctrl + Delete> ลบค�ำทางขวาของเคอร์เซอร์จ�ำนวน 1 ค�ำ

<Ctrl + Enter> รันเซลล์ที่ถูกเลือกในขณะนั้น

<Shift + Enter> รันเซลล์ที่ถูกเลือก แล้วเลือกเซลล์ถัดไป (ถ้าไม่มีจะสร้างใหม่)

<Alt + Enter> รันเซลล์ที่ถูกเลือก แล้วสร้างเซลล์ใหม่ถัดจากเซลล์ที่รัน

<Ctrl + S> บันทึกการเปลี่ยนแปลงลงในไฟล์

•• Code Completion (กรณีของ Jupyter อาจเรียกอีกอย่างว่า Tab Completion) คือการน�ำสิ่งที่ 

อาจเป็นไปได้มาแสดงให้เราเลือก เพื่อเตมิลงในโค้ด ซึง่ถ้าเราใช้งานเป็น กจ็ะประหยดัเวลาในการพมิพ์ 

ได้เล็กน้อย ดังแนวทางในภาพถัดไป
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•• เนื่องจากไพธอน เป็นภาษาทีต้่องอาศยัการเยือ้งโค้ดในการก�ำหนดขอบเขตของบลอ็ก ดงันัน้ หากเรา

จะเพิ่มการเยื้อง ควรกด <Ctrl + ]> หรือ <Tab> มากกว่าที่จะกด <Spacebar> หลายๆ ครั้ง เพราะ

อาจเกิดข้อผิดพลาดได้ หากระยะเยื้องไม่เท่ากัน

การตรวจสอบข้อมูลของออบเจ็กต์
ลักษณะท่ีควรรูเ้พิม่เตมิอกีอย่างคือ หากเราต้องการดขู้อมลูเกีย่วกบัตวัแปร ฟังก์ชนั หรอืออบเจก็ต์บางตวั  

ให้เขยีนช่ือของมนัลงไปแล้วตามด้วยเครื่องหมาย ? จากนัน้รนัเซลล์ เช่น กด <Ctrl + Enter> ซึง่เทคนคิดงักล่าวนี ้

เรยีกว่า Object Introspection เช่น ถ้าเราอยากทราบว่าฟังก์ชนั print() หรือฟังก์ชนั insert() ของตวัแปรลสิต์  

มีอาร์กิวเมนต์อะไรบ้าง ก็ท�ำดังนี้

inspiration starts here



27 บทที่ 1  การใช้ Jupyter และ Colab

นอกจากนี้ยังสามารถท�ำได้อีกวิธี นั่นคือ การใช้ฟังก์ชัน help() ของ Jupyter โดยระบุชื่อฟังก์ชัน ตัวแปร 

หรือออบเจ็กต์ที่เราต้องการทราบค่า เป็นอาร์กิวเมนต์ให้กับ help() แล้วรันเซลล์นั้น 

ทางเลือกในการแสดงผล
ส�ำหรับการเขยีนโค้ดใน Jupyter หากเราต้องการแสดงค่าของตวัแปรตวัใดตวัหนึง่ กอ็าจใช้ค�ำส่ัง print()  

ซ่ึงเป็นของไพธอนได้ตามปกต ิหรอืจะระบแุค่ชื่อตวัแปรกไ็ด้ แต่ลกัษณะผลลพัธ์จะแตกต่างกนับ้างเลก็น้อย เช่น

ในภาพต่อไปนี้
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อย่างไรก็ตาม ทั้งสองกรณีดังที่กล่าวมา มีสิ่งที่ควรพิจารณาดังนี้

•• การใช้ค�ำสั่ง print() ตามปกติใน Jupyter จะแสดงข้อมูลในบรรทัดใหม่ให้โดยอัตโนมัติ หรืออาจใช้  

'\n' เพ่ือขึน้บรรทดัใหม่เหมอืนกบัในโปรแกรม IDE อื่นๆ ดงัในภาพถดัไป หรอือาจใช้ print() โดยไม่ระบุ 

อาร์กิวเมนต์ส�ำหรับการแทรกบรรทัดว่างก็ได้
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•• การระบุแค่ชื่อตัวแปร จะท�ำได้เพียงกรณีที่เราแสดงผลค่าของตัวแปรใดตัวแปรหนึ่ง และต้องวางให้ 

เป็นค�ำสัง่สดุท้าย แล้วต่อจากน้ันจะมคี�ำสัง่อื่นๆ อกีไม่ได้ (ถ้ามต่ีอจากนัน้ ค่าของตวัแปรจะไม่ปรากฏ) เช่น
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•• นอกจากวิธีการดังที่กล่าวมาแล้ว  ใน Jupyter ยังมีค�ำสั่ง display() เพื่อใช้ในการแสดงข้อมูล ซึ่ง

มีข้อดีคือ สามารถแสดงข้อมูลหรือตัวแปรหลายๆ ตัวพร้อมกันได้ในค�ำสั่งเดียวกัน โดยมีบรรทัดว่าง

คั่นระหว่างแต่ละค่าให้โดยอัตโนมัติ เช่น

แต่ขอให้จ�ำไว้ว่า ค�ำสั่ง display() เป็นของ Jupyter ดังนั้น เราจะน�ำไปใช้กับ IDE ตัวอื่นๆ ไม่ได้ ซึ่งใน

หนังสือเล่มนี้ อาจใช้ร่วมกันทั้ง 3 แบบดังที่กล่าวมา ตามความเหมาะสมของแต่ละกรณี

การแก้ปัญหา Jupyter ในเบื้องต้น
การใช้ Jupyter อาจเจอปัญหาเบื้องต้นที่อาจเกิดขึ้นในบางครั้ง ซึ่งผู้เขียนมีค�ำแนะน�ำดังนี้
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•• เมื่อเปิดเข้าสูว่นิโดว์ Jupyter Notebook Server แล้ว บางคร้ังอาจต้องใช้เวลาเลก็น้อยกว่าจะปรากฏ

เว็บเบราเซอร์เพื่อเข้าสู่หน้า Home Page ของ Jupyter อย่างไรก็ตาม หากรอนานจนผิดปกติ แต่ยัง 

ไม่เข้าสู่หน้าจอของ Home Page ให้คลิกวินโดว์ Server  แล้วกด <Ctrl + Z> จากนั้นรอสักครู่ หาก

ไม่ได้ผลจริงๆ ก็ต้องปิดวินโดว์ Server แล้วเปิดเข้ามาใหม่

•• เมื่อเรารนัโปรแกรมทีเ่ซลล์ใดๆ กต็าม แต่ถ้ารอนานแล้วกไ็ม่มีผลลพัธ์ปรากฏขึน้ ซึง่เราอาจแก้ปัญหา

เหมือนกับข้อที่แล้วคือ คลิกที่วินโดว์ Server ให้อยู่สถานะ Active แล้วกด <Ctrl + Z> จากนั้นรอ

สักครู่ ถ้าไม่ได้ผลก็ลองกดซ�้ำหลายๆ ครั้ง

•• หรืออีกวิธีส�ำหรับกรณีที่ผลลัพธ์ไม่ปรากฏ เราอาจคลิกปุ่ม Restart Kernel หรือเลือกที่เมนู Kernel 

> Restart แล้วรอจนกว่า Kernel จะเริ่มการท�ำงานใหม่ จากนั้นค่อยรันเซลล์ที่มีปัญหาอีกครั้ง

•• ในบางครั้ง แม้เราจะแก้ไขโค้ดในเซลล์นั้นแล้ว แต่เมื่อรันเซลล์ดังกล่าว กลับได้ผลลัพธ์เหมือนกับ

ตอนที่ยังไม่แก้ หรือมีบางอย่างไม่อัปเดตตามโค้ด ก็ให้ลอง Restart Kernel ใหม่ ดังวิธีการที่ได้

กล่าวไว้ในข้อที่แล้ว

การใช้งาน Google Colab
Google Colab เป็นความร่วมมอืระหว่างทมีผูส้ร้าง Jupyter Notebook และ Google ดงันัน้ จงึมลีกัษณะ

ที่คล้ายคลึงกัน แต่ต้องใช้งานผ่านเว็บ หรือกล่าวได้ว่า Google Colab ก็เหมือนกับเป็น Jupyter Notebook 

แบบออนไลน์นั่นเอง ซึ่งข้อดีของการใช้ Colab คือ

•• ใช้งานผ่านเว็บ จึงไม่ต้องติดตั้งภาษาไพธอนหรือไลบรารีในเครื่องใดเครื่องหนึ่ง

•• สามารถเข้าถึงได้จากทุกอุปกรณ์ที่เชื่อมต่อกับอินเทอร์เน็ตได้

•• จัดเก็บไฟล์ของโค้ดใน Google Drive หรือ GitHub จึงสามารถเข้าถึงและน�ำมาใช้งานได้ทุกอุปกรณ์

ที่เชื่อมต่อกับอินเทอร์เน็ต

แม้ว่าในหนังสือเล่มนี้ จะเน้นการใช้ Data Science ด้วย Jupyter Notebook เป็นหลัก แต่ก็จะแนะน�ำ

แนวทางของ Colab พอสังเขป เผื่อจะมีผู้อ่านบางท่านที่สนใจจะใช้แนวทางนี้ ซึ่งขั้นตอนหลักๆ คือ
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1.	 ต้องมีบัญชีผู้ใช้ที่เป็นของ Google เช่น Gmail ถ้ายังไม่มี ก็ต้องไปสมัครให้เรียบร้อยก่อน

2.	 สมัครเข้าใช้บริการ Google Drive (https://drive.google.com)

3.	 ท่ี Google Drive เราต้องสร้างโฟลเดอร์เพื่อเชื่อมโยงกบั Colab ส�ำหรบัจดัเกบ็ไฟล์ของโค้ด ดงัขัน้ตอน 

ต่อไปนี้

๏๏ ถ้ายังไม่เคยสร้างโฟลเดอร์ Colab มาก่อน ให้คลิกปุ่ม [+ ใหม่] หรือไดรฟ์ของฉัน > เพิ่มเติม > 

เชื่อมต่อแอปเพิ่มเติม

๏๏ พิมพ์ค�ำว่า colab ลงในช่องค้นหา เมื่อรายการ Google Colaboratory ปรากฏขึ้น ก็ให้คลิกปุ่ม

เชื่อมต่อ แล้วคลิกปิด

๏๏ ที่หน้าจอหลักของ Google Drive ให้คลิกปุ่ม [+ ใหม่] หรือไดรฟ์ของฉัน > เพิ่มเติม > Google 

Colaboratory หลังจากนั้น โฟลเดอร์ที่ชื่อ Colab Notebooks จะถูกสร้างขึ้น
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4.	 การเข้าสู่ Colab ให้เข้าไปที่ https://colab.research.google.com จากนั้น 

(1)	คลิกที่แท็บ GOOGLE DRIVE

(2)	คลิกที่ลิงก์ NEW PYTHON 3 NOTEBOOK

2

1

5.	 ที่หน้าจอหลัก ก็จะแบ่งเป็นเซลล์ให้เราเขียนโค้ด คล้ายกับ Jupyter Notebook ส่วนการรัน นอกจาก

การคลิกที่ไอคอนหัวลูกศรด้านหน้าเซลล์แล้ว ก็อาจใช้วิธีกด <Shift + Enter> หรือ <Alt + Enter> 

หรือ <Ctrl + Enter> เช่นเดียวกับ Jupyter ซึ่งการรัน อาจต้องใช้เวลาเล็กน้อย กว่าผลลัพธ์จะ

ปรากฏให้เห็น เพราะเป็นการประมวลผลทางฝั่งเซิร์ฟเวอร์ ทั้งนี้ก็ขึ้นกับลักษณะของโค้ดที่เราเขียน
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6.	 หากต้องการจัดการเกี่ยวกับเซลล์ ก็สามารถเลือกจากแผงทูลบาร์ที่ปรากฏตรงมุมขวาบนของเซลล ์

ที่เราเลือกในขณะนั้นได้เลย หรือหากต้องการเพิ่มเซลล์ใหม่ก็อาจคลิกที่ปุ่ม [+ Code]

7.	 ปกติ ชื่อไฟล์จะถูกก�ำหนดเป็น UntitledX.ipynb เช่นเดยีวกบั Jupyter ถ้าต้องการเปลีย่น กค็ลกิทีช่ื่อ 

ดังกล่าวแล้วพิมพ์ชื่อใหม่ลงไปได้เลย และถ้าจะบันทึกไฟล์ ก็เลือกที่เมนู File > Save

8.	 ไฟล์จะถูกบันทึกใน Google Drive ซึ่งหากเราเปิดเข้าไปดูในโฟลเดอร์ Google Laboratory ก็จะเห็น

รายชื่อไฟล์ทั้งหมดที่ได้บันทึกเอาไว้

9.	 ถ้าต้องการเปิดไฟล์ ก็คลิกขวาที่ไฟล์เป้าหมายแล้วเลือก เปิดด้วย > Google Colaboratory

เนื่องจากไฟล์ของ Colab บนัทกึเป็น .ipynb เช่นเดยีวกบัของ Jupyter ดงันัน้ เราสามารถดาวน์โหลดไฟล์

ที่เขียนด้วย Colab มาเปิดด้วย Jupyter ก็ได้ หรือจะอัปโหลดไฟล์ที่เขียนด้วย Jupyter ไปไว้บน Google Drive 

แล้วเปิดด้วย Colab ก็ได้เช่นเดียวกัน ส่วนลักษณะการใช้งานอื่นๆ ขอให้ผู้อ่านลองศึกษาเพิ่มเติมด้วยตนเอง  

หรือบางกรณีก็สามารถน�ำแนวทางของ Jupyter มาใช้ได้
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การน�ำโค้ดของหนังสือมาใช้งาน
หากผู้อ่านต้องการน�ำโค้ดที่ใช้ประกอบในหนังสือเล่มนี้มาใช้งาน สามารถดาวน์โหลดได้ที่ http://www.

developerthai.com ซึ่งจะได้ไฟล์ python-data-sci.zip ที่ประกอบด้วยโค้ดตั้งแต่บทที่ 1 - 14 (chap1.ipynb  

- chap14.ipynb) และโฟลเดอร์ data-sci ให้ขยายไฟล์แล้วน�ำทั้งหมดไปเก็บไว้ที่ C:\Users\ชื่อผู้ใช้\

โดยล�ำดบัโค้ด (เซลล์) ของแต่ละไฟล์ก็ตรงตามล�ำดับทีป่รากฏในหนงัสอืของบทนัน้ๆ ต่อเนื่องกนัไป และ

หากผู้อ่านต้องการจัดรูปแบบโค้ดให้แสดงผลตามที่เห็นในหนังสือ ก็มีค�ำแนะน�ำดังนี้

•• ตั้งค่าให้ Chrome เป็น Default Browser

•• ตั้งค่าฟอนต์แบบความกว้างคงที่ โดยเลือกชนิด Consolas

สิง่ท่ีได้กล่าวถงึในบทนี ้เป็นเพยีงการเตรยีมความพร้อมส�ำหรับการเขยีนและทดสอบโค้ด ทีจ่ะกล่าวถงึใน

บทต่อๆ ไป ซึ่งผู้อ่านควรฝึกฝนการใช้ Jupyter Notebook ให้เกิดความคุ้นเคยในระดับหนึ่ง มิฉะนั้นอาจสร้าง

ปัญหาต่อการเรียนรู้ในขั้นตอนต่อจากนี้ได้
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