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 ython เปนหนึ่งในภาษาคอมพิวเตอรที่ไดรับความนิยมสูงสุดในปจจุบัน ซึ่งนอกจากจะงายตอการเรียนรู 

 แลว ยังสามารถนําไปประยุกตใชงานไดหลากหลายรูปแบบ โดยเนื้อหาในบทนี้จะกลาวถึงการติดตั้ง 

เครื+องมือสําหรับการเขียนโคด พรอมทั้งการต้ังคาที่จําเปนตองทราบในเบื้องตน ซึ่งผูอานควรใชงานใหเกิด 

ความคุนเคยในระดับหนึ่งกอน ทั้งนี้ก็เพื+อประโยชนตอการเรียนรูในบทตอ ๆ  ไป

เกี่ยวกับภาษา Python 
ภาษาไพธอน (Python Language) สรางขึ้นเมื+อป ค.ศ. 1994 โดย

โปรแกรมเมอรชาวดัตชที่ชื+อ Guido van Rossum ดวยพื้นฐานจากหลายภาษา

รวมกัน เชน C, ABC, Modular-3, Algol-68, SmallTalk, Unix Shell เปนตน 

เพื+อใหเปนภาษาคอมพิวเตอรที่เรียนรูไดงาย ไมมีกฎเกณฑหรือหลักไวยากรณที่ 

ซับซอน และสามารถนําไปใชบนระบบปฏิบัติการท่ีแตกตางกันได ปจจุบันไพธอน 

จดัอยูในกลุม Top-5 ของภาษาคอมพวิเตอรทีม่ผีูใชงานมากท่ีสดุ จงึเปนสิง่ทีย่นืยนั

ถึงความสําเร็จไดเปนอยางดี และนอกจากนี้ก็ยังมีลักษณะที่น�าสนใจอื+น ๆ  คือ

 Free - สามารถนํามาใชงานไดฟรี โดยไมมีคาใชจายหรือเงื+อนไขใด ๆ

 Easy to Use & Learn - มีโครงสรางทางภาษาที่เรียบงาย และสามารถเรียนรูไดเร็ว จึงเหมาะ 

อยางยิ่งสําหรับผูเริ่มตนศึกษาการเขียนโปรแกรม

Python, VS Code  
และ Jupyter
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 General Purpose - ไพธอนเปนภาษาแบบเอนกประสงคที่เราสามารถใชในการโปรแกรมได 

หลากหลายรปูแบบ นบัตัง้แตแอปพลเิคชนัทัว่ไป เว็บแอปพลเิคชนั การเขียนโปรแกรมสําหรบัเครือขาย  

หรือการคํานวณทางวิทยาศาสตร เปนตน 

 Portable - สามารถนาํโปรแกรมท่ีเขยีนดวยไพธอนบนระบบปฏบิตักิารหน่ึง ไปใชบนอกีระบบหนึง่ได 

เชน เราอาจเขียนโปรแกรมบน Windows แลวนําไปใชงานบนเครื+อง Mac หรือ Linux เปนตน หรือ

เรียกวาการทํางานขามแพลตฟอรม (Platform) นั่นเอง

 Open Source - ไพธอนเปนภาษาแบบเปดเผย Source Code ภายใตลขิสทิธิข์อง Python Software 

Foundation ดงัน้ัน จึงมกีลุมอาสาสมคัรเขารวมพฒันาอยางมากมาย ชวยใหภาษามีววิฒันาการอยาง

ตอเนื+อง

 Functional & OOP - สามารถเลอืกเขยีนโปรแกรมไดทัง้แบบ Functional และแบบ Object-Oriented

 GUI Programming - ไพธอนสนบัสนุนการเขยีนโปรแกรมแบบ Graphic User Interface เพื+อตดิตอ

และโตตอบกับผูใชแบบกราฟก ซึ่งสามารถนําไปใชงานบนระบบปฏิบัติการที่แตกตางกันได

 Databases - ไพธอนมีไลบรารีที่สนับสนุนการเชื+อมตอกับโปรแกรมฐานขอมูลหลัก ๆ  เกือบทั้งหมด

 Automatic Memory Management - ภาษาไพธอนมีกลไกจัดการหน�วยความจําแบบอัตโนมัติ จึง

ชวยลดขอผิดพลาดจากการเกิดปญหา Memory Leak และสงผลใหโปรแกรมทํางานไดอยางคงทน

 Large Community & Support - ภาษาไพธอนมีชุมชนหรือกลุมผูใชขนาดใหญ ที่พรอมใหการ

สนับสนุนและชวยเหลือเมื+อเราเกิดปญหา

 Support Libraries - นอกจากไลบรารีแบบ Built-in ที่มากับภาษาไพธอนเองแลว เราสามารถนํา

ไลบรารีจากภายนอก หรือ Third-Party Libraries เขามาเสริมการทํางานไดอีกดวย จึงเกิดทางเลือก

ในการพัฒนาแอปพลิเคชันที่หลากหลายยิ่งขึ้น

การติดตั้งภาษา Python
กอนที่เราจะสามารถทดสอบการทํางานตาง ๆ  ได จําเปนตองติดตั้งตัวประมวลผลของภาษาไพธอนลงไป

กอน โดยมีขั้นตอนที่สําคัญดังนี้
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1. เราสามารถดาวนโหลดชุดติดตั้งไดจากเว็บไซต https://www.python.org/downloads

2. หลังจากดาวนโหลดเสร็จ ก็ดับเบิลคลิกไฟลที่ไดมา เมื+อปรากฏหนาจอที่แสดงฟเจอร (Feature)  

ในการติดตั้ง สิ่งที่ควรเลือกคือ

1) Add Python X.XX (หมายเลขเวอรชัน) to PATH

2) คลิกที่กรอบ Install Now เพื+อเลือกติดตั้งองคประกอบที่จําเปนตอการใชงานทั่ว ๆ  ไปทั้งหมด 

1

2
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3. หลังจากนั้น จะเขาสูขั้นตอนการติดตั้ง ก็ใหเรารอจนกวาจะเสร็จสิ้น

หลังจากติดตั้งภาษาไพธอนลงไปแลว สิ่งที่เราตองพิจารณาในลําดับถัดไปคือ การเลือกเครื+องมือในการ

เขียนโคด ซ่ึงมีตัวเลือกคอนขางมาก และตางก็มีขอดีขอเสียที่แตกตางกัน สําหรับในหนังสือเลมนี้ ผูเขียนจะ

เลือกใช Jupyter บน VS Code เปนหลัก ดังรายละเอียดที่จะกลาวถึงในหัวขอตอ ๆ  ไป

การใชงาน Visual Studio Code (VS Code)
Visual Studio Code หรือโดยทั่วไปเรามักเรียกส้ัน ๆ  วา VS Code เปนโปรแกรมประเภท IDE  

(Integrated Development Environment) ที่ Microsoft สรางขึ้นมาสําหรับใชในการเขียนโคดทั่ว ๆ  ไป และ

ไดรับความนิยมสูงสุดในปจจุบัน เนื+องจากมีลักษณะที่โดดเดนหลายประการ เชน ใหใชงานฟรี รองรับการเขียน

โคดไดหลายภาษา และที่สําคัญคือ มีสวนเสริมการทํางานใหเลือกใชมากมาย แมในหนังสือเลมนี้จะเนนการใช 

Jupyter เปนหลัก แตก็ตองทํางานอยูบนพื้นฐานของ VS Code (ใชงานรวมกัน) ดังนั้น จึงจําเปนตองรูจักวิธี

การใชงานบางอยางเกี่ยวกับ VS Code เอาไวลวงหนา โดยสิ่งที่เราควรรูในเบื้องตนมีดังนี้
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การติดตั้ง VS Code
สําหรับการติดตั้ง VS Code ลงในเครื+องที่เราจะใชงาน มีขั้นตอนโดยสังเขปคือ

1. สามารถดาวนโหลดชุดติดตั้งไดที่ https://code.visualstudio.com/download

2. หลังจากดาวนโหลดเสร็จ ใหดับเบิลคลิกไฟลติดตั้งที่ไดมา จากนั้นในหนาจอถัดไป ก็ยอมรับเงื+อนไข

แลวคลิกปุม Next (ดังภาพถัดไป ดานซายมือ)

3. ขั้นตอนตอไป จะมีออปชันใหเลือก ก็แนะนําใหเลือกทั้งหมด แลวคลิกปุม Next

1

2

1

2

4. ตอจากนั้น คลิกปุม Install เพื+อเริ่มการติดตั้งไฟล จากนั้นก็รอจนกวาจะแลวเสร็จ
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หนาจอ Welcome (Get Started)
เมื+อเราเปดเขาสู VS Code ตามปกติ จะปรากฏหนาจอ Welcome (หรือ Get Started) เปนอันดับแรก 

ซึ่งลักษณะที่สําคัญเกี่ยวกับหนาจอนี้คือ

 อาจมีการแจงขอมูลขาวสารที่น�าสนใจเกี่ยวกับ VS Code

 มีลิงกสําหรับใหเราคลิกเพื+อเปดไฟลหรือโฟลเดอรเปาหมายที่ตองการไดอีกหนึ่งวิธี นอกเหนือจาก

การเลือกที่เมนู

 มลีงิกทีแ่สดงประวตักิารเปดโฟลเดอรทีเ่ราเขาสู VS Code ในครัง้กอน ๆ  ซึง่หากมโีฟลเดอรเปาหมาย

ที่เราตองการรวมอยูดวย ก็สามารถคลิกเปดจากตรงนี้ไดทันที

หากเราตองการปดหนาจอนี้ ก็คลิกปุม X ที่แท็บดานบน หรือหากไมตองการใหปรากฏหนา Welcome 

(Get Started) ตอไปอีก ก็ใหเราเอาเครื+องหมายถูกตรงตัวเลือก Show welcome page on startup ที่บริเวณ

ขอบดานลางออก หรือหลังจากปดไปแลว หากเราตองการใหหนาจอ Welcome กลับมาแสดงอีกครั้ง ก็ใหเลือก

ที่เมนู Help > Get Started 
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การเลือกรูปแบบสี (Theme)
ตามปกต ิVS Code จะเลอืกธมี (Theme) เปนสดีาํ (Dark) เอาไวลวงหนา ซึง่หากเราชอบแบบนี ้กไ็มจาํเปน 

ตองปรับเปลี่ยนก็ได แตถาเราตองการสีสันในรูปแบบอื+น ก็สามารถเปลี่ยนแปลงได ซึ่ง VS Code มีตัวเลือกอยู

จํานวนหนึ่ง โดยใชขั้นตอนดังนี้

1. ที่มุมลางขวาของโปรแกรม VS Code ใหคลิกที่ไอคอน Manage (รูปเฟอง)

2. เลือกที่เมนู Color Theme

จากนัน้จะปรากฏรายชื+อสใีหเลอืก ถาเรายงัไมทราบวาแตละสมีลีกัษณะเปนยงัไง กอ็าจลองเลอืกดกูอนกไ็ด 

ถาไมถกูใจกค็อยเลอืกสใีหม สาํหรบัทีใ่ชประกอบในหนงัสือเลมนี ้ผูเขยีนจะเลอืกธมีสแีบบ Light (Visual Studio)

1

2

3

การปรับเปลี่ยนฟอนต
ฟอนต (Font: ในที่นี้คือตัวอักษรที่ใชเขียนโคดและแสดงผลลัพธ) ที่ VS Code กําหนดเอาไวลวงหนา 

แมจะเปนรูปแบบมาตรฐานที่นิยมใชงานกันทั่วไป แตหากตองการใชฟอนตที่เราถูกใจ ก็สามารถเปลี่ยนแปลงได

ดวยขั้นตอนดังตอไปนี้
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1. ที่มุมลางขวาของโปรแกรม VS Code ใหคลิกที่ไอคอน Manage (รูปเฟอง)

2. เลือกที่เมนู Settings

3. คลิกแท็บ Text Editor

4. คลิกแท็ก Font

5. กําหนดชื+อฟอนตลงในชอง Font Family ซึ่งตามปกติ จะมีฟอนตเดิมที่ VS Code กําหนดไวใหลวง

หนา หากเราตองการเปลีย่นไปใชชนดิอื+น ควรเพิม่ชื+อฟอนตไวขางหนาฟอนตเดมิ (ชื+อทีอ่ยูกอน จะถกู 

พิจารณากอน และไมแนะนําใหลบชื+อฟอนตเดิมออก) โดยคั่นดวยเครื+องหมาย , และถาชื+อฟอนต

ชนดินัน้มชีองวาง ใหเขยีนไวในเครื+องหมาย ' ' ซึง่ชื+อฟอนตทีร่ะบ ุตองถกูตดิตัง้เอาไวในเครื+องนัน้อยู

กอนแลว (การติดตั้งฟอนต ใหคัดลอกไฟลของฟอนตไปไวที่ C:\Windows\Fonts แลวเริ่มโปรแกรม

ที่จะใชฟอนตใหม)

6. ถาตองการกําหนดขนาด ก็ระบุ

ตวัเลขลงในชอง Font Size และ

เมื+อปดหนาจอ Setting ฟอนตที่

ตั้งคาเอาไว ก็จะมีผลทันที

นอกจากนี้ ยังมีเทคนิคเพิ่มเติมอีกอยางคือ การยอหรือขยาย (Zoom) ขนาดของฟอนตในโปรแกรม VS 

Code ใหใหญขึ้นหรือเล็กลง ซึ่งกรณีนี้ จะมีผลกับทั้งโคด เมนู และขอความอื+น ๆ  ทั้งหมดบน VS Code โดย

ใชวิธีการงาย ๆ  คือ

2

1

3

4

5

6
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 หากตองการขยายขนาดเพิ่มขึ้น (Zoom In: คลายกับการเขาไปมองใกล ๆ  ซึ่งจะเห็นขนาดที่ใหญขึ้น) 

ใหกดคียบอรดปุม <Ctrl => หรือเลือกเมนู View > Appearance > Zoom In ซึ่งหากทําซํ้าเชนนี้

อีก ขนาดของฟอนตจะเพิ่มขึ้น 1 ระดับไปเรื+อย ๆ

 หากตองการลดขนาดใหเล็กลง (Zoom Out: คลายกับการออกมามองไกล ๆ  ซ่ึงเราจะเห็นขนาดที่ 

เล็กลง) ใหกดคียบอรดปุม <Ctrl -> หรือเลือกเมนู View > Appearance > Zoom Out ซ่ึงหาก

ทําซํ้าเชนนี้อีก ขนาดของฟอนตจะลดลง 1 ระดับไปเรื+อย ๆ

การเขียนโคด Python บน VS Code โดยตรง
แมในหนังสือเลมนี้จะเนนการเขียนโคดบน Jupyter ในรูปแบบสวนเสริมของ VS Code ดังที่จะกลาวถึง 

ในหัวขอถัดไป แตเราก็ควรมีพื้นฐานการเขียนโคดบน Editor ของ VS Code เอาไวบาง ซึ่งอาจตองนําไปใชงาน 

ในบางโอกาส ดังนั้น จึงจะแนะนําแนวทางไวพอสังเขป แตอยางไรก็ตาม VS Code มีเพียงหนาที่เกี่ยวกับ 

การเขียนโคดเทาน้ัน แตการประมวลผลคําสั่ง (Compile) เปนหนาที่ของตัวแปลภาษาไพธอน ดวยเหตุนี้  

เราจําเปนตองติดตั้งภาษาไพธอนเอาไวกอนแลว จึงจะทดสอบการทํางานได และหากเราติดตั้งภาษาไพธอน 

ดังที่กลาวไปในหัวขอกอนนี้ ก็สามารถใชงานไดเลย

จากภาพ เปนหลกัการโดยสงัเขปในการทาํงานของภาษาไพธอน กลาวคือ เราจะเขยีนโคดบน Editor ของ 

VS Code จากนั้น เมื+อสั่งรัน (Run) โคดจะถูกสงไปประมวลผลยังตัวแปลภาษาไพธอน แลวผลลัพธที่ไดจะถูก

สงกลับมาแสดงผลที่สวน Terminal ของ VS Code

สําหรับขั้นตอนการเขียนโคดบน VS Code มีแนวทางโดยสังเขปดังนี้

1. ตามหลกัการของ VS Code เราควรสรางโฟลเดอรสาํหรบัเกบ็ไฟลไวตางหาก ซึง่ในท่ีนีผู้เขยีนจะสราง

โฟลเดอรชื+อ python ไวที่ตําแหน�ง c:\python
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2. เมื+อเปดเขาสู VS Code ใหเปดโฟลเดอรที่ใชเก็บโคดไพธอนที่สรางเอาไว เชน เลือกที่เมนู File > 

Open Folder จากนั้น ก็เลือกโฟลเดอรดังกลาว (ในที่นี้คือ c:\python)

3. หลังจากนั้น ใหเราสรางไฟลเพิ่มเขามาใน

โฟลเดอร ดังนี้

1) คลิกที่ไอคอน New File

2) กําหนดชื+อไฟลลงไป โดยตองมีสวน

ขยายเปน .py เทานั้น

4. ตอไป ก็เขียนโคดภาษาไพธอนลงใน Editor ไดเลย แลวบันทึกการเปลี่ยนแปลง เชน กด <Ctrl + S>  

หรือเลือกจากเมนู File > Save

5. หากตองการรนั ใหคลกิทีปุ่มไอคอนหวัลกูศรตรงมุมขวาบน ซึง่ไอคอนนีจ้ะปรากฏเมื+อเราอยูในมุมมอง

การเขียนโคดภาษาไพธอนเทานั้น

6. หลงัการสัง่รนั หากโคดไมมขีอผดิพลาด ก็จะถกูสงไปประมวลผลยงัตวัแปลภาษาไพธอนแลวผลลพัธ

ที่ไดก็จะปรากฏที่ Terminal ดานลาง ดังหลักการที่กลาวมาแลว

หากเราจะทดสอบในกรณีอื+น ๆ  ถาไมจําเปนตองเก็บโคดเดิมเอาไว ก็สามารถลบทิ้ง แลวเขียนโคดใหม 

ลงไปแทนไดเลย แตหากตองการเกบ็โคดเดิมเอาไว เราตองสรางไฟลใหมเพิม่เขามาในโฟลเดอรดวยหลกัการเดมิ 

ทัง้หมด แลวเมื+อเลกิใชงาน ก็ควรปดโฟลเดอรโดยเลอืกทีเ่มน ูFile > Close Folder และในการใชงาน VS Code  

คราวตอไป ก็อาจทําแบบใดแบบหนึ่งดังนี้

1

2
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  วิธีที่ 1 เลือกเปดโฟลเดอรที่เก็บไฟลของโคดเอาไว เชน เลือกเมนู File > Open Folder จากนั้น

เลือกโฟลเดอรที่จัดเก็บโคดไพธอนเอาไว

  วิธีที่ 2 อาจเลือกเปดไฟลแบบเจาะจงก็ได เชน เลือกเมนู File > Open File จากนั้นเลือกไฟลที่

จัดเก็บโคดไพธอนเอาไว (.py) แลวเมื+อเลิกใชงาน ก็ควรปดไฟลโดยเลือกที่เมนู File > Close Editor

ในการเปดใชงาน VS Code ครั้งตอ ๆ  ไป ถามีรายชื+อโฟลเดอรหรือไฟลเปาหมาย ปรากฏบนหนาจอ 

Welcome (Get Started) ก็สามารถคลิกที่ลิงกเพื+อเปดจากตรงนั้นเลยก็ได

Jupyter สําหรับ VS Code
กรณีที่เราเริ่มตนศึกษาการเขียนโคด อาจมีเนื้อหาปลีกยอยหลายอยางที่เราจําเปนตองทดสอบอยูตลอด  

ซึ่งหากเราตองการนําโคดกลับมาใชงานใหม ก็ตองจัดเก็บโคดเหลานั้นแยกไวคนละไฟล ดังนั้น ถาเราทดสอบ 

100 ตัวอยาง ก็ตองสราง 100 ไฟล เปนตน นี่จึงกลายเปนความยุงยากอีกอยางหนึ่งของการเรียนรูในเบื้องตน

จากปญหาดังที่กลาวมา เราอาจเปลี่ยนมาเขียนโคดดวยเครื+องมืออีกแบบหนึ่ง ซึ่งสามารถจัดเก็บโคด 

การทดสอบปลกียอยหลาย ๆ  อัน รวมไวในไฟลเดยีวกนัได โดยเราเรียกเครื+องมอืนีว้า Jupyter Notebook (อาจ

เรียกสั้น ๆ  วา Jupyter) ซึ่งมีลักษณะที่น�าสนใจดังนี้
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 Jupyter จะแบงพื้นที่สําหรับการเขียนโคดออกเปนชอง ๆ  ซึ่งเรียกวาเซลล (Cell)

 ในไฟลเดียวกัน สามารถสรางไดมากกวา 1 เซลล

 เราสามารถเขียนโคดเพื+อทดสอบในแตละเรื+องโดยแยกไวคนละเซลล และสามารถรันเพื+อดูผลลัพธ

เฉพาะโคดที่อยูในเซลลใดเซลลหนึ่งไดเลย

ตามปกติ เราสามารถใช Jupyter ไดหลายแนวทาง เชน ติดตั้งผานชุด Anaconda หรือใชงานผาน 

Google Colab เปนตน แตวิธีเหลาน้ี จะใชงานในแบบเว็บแอปพลิเคชัน ซึ่งอาจมีขั้นตอนที่ยุงยากเล็กนอย

สําหรับผูเริ่มตน และนอกจากวิธีการดังกลาว ก็ยังมีทางเลือกใหเราสามารถนํา Jupyter มาใชรวมกับ VS Code 

ในรูปแบบของสวนเสริม (Extension) ไดเชนกัน โดยเราตองติดตั้งเพิ่มเติมลง VS Code ดังขั้นตอนตอไปนี้

1. ที่ VS Code ใหคลิกที่ไอคอน Extension ที่แถบดานซาย

2. พิมพคําวา Jupyter ลงในชองคนหา (ขณะนั้นตองเชื+อมตออินเทอรเน็ต)

3. ตามปกติ ผลการคนหาจะมีรายการที่ชื+อ Jupyter (ที่ผานการตรวจสอบจาก Microsoft แลว) และ

ถามีไอคอนรูปเฟองปรากฏที่กรอบรายการดังกลาว แสดงวา Jupyter ถูกติดตั้งเอาไวแลว ซึ่งเราไม

จําเปนตองทําอะไรตอ สามารถคลิกที่ไปไอคอน Extension (เชนเดียวกับขอ 1) เพื+อปดหนาจอการ

คนหาสวนเสริมไดเลย

2

1

3

4

4. แตหากที่กรอบรายการ Jupyter (ผลการ

คนหา) ปรากฏปุมที่มีคําวา Install แสดง

วายังไมไดติดตั้ง Jupyter ก็ใหเราคลิกปุม

ดังกลาวเพื+อติดตั้งลงใน VS Code ไดเลย
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อยางไรก็ตาม Jupyter ก็เปนเพียงเครื+องมือในการเขียนโคดเชนเดียวกับ VS Code แตหนาที่ในการ

ประมวลผลคําสัง่ก็เปนของตวัแปลภาษาไพธอนอกีเชนกนั ดังนัน้ เราตองตดิตัง้ภาษาไพธอนเอาไวกอนแลวจงึจะ

รนัทดสอบ Jupyter ได โดยลกัษณะการทาํงานรวมกนัระหวาง VS Code กับ Jupyter และ Python เปนดงัภาพ

การสรางไฟลของ Jupyter
การใชงาน Jupyter ในแบบสวนเสริมของ VS Code นั้น เราตองสรางและเปดไฟลที่เปนรูปแบบของ 

Jupyter เครื+องมือตาง ๆ  จึงจะปรากฏใหเห็น โดยไฟลของ Jupyter นั้นตองมีสวนขยายเปน .ipynb (มาจาก 

Interactive Python Notebook ซึง่เปนชื+อเดิมของ Jupyter) ซึง่แนวทางการสรางไฟลอาจทาํแบบใดแบบหน่ึงคอื

  วิธีที่ 1 เปดเขาสู VS Code แลวทําตามขั้นตอนดังนี้

1) เลือกเมนู File > New File... (ตองเปนเมนู New File อันที่สอง ไมใชอันบนสุด) หรือคลิกที่ลิงก 

New File... บนหนาจอ Welcome (Get Started) ก็ได

2) เลือกชนิดไฟลเปน Jupyter Notebook

1

2
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3) หลงัจากน้ัน จะเขาสูมมุมองของ Jupyter ซึง่ไฟลจะถกูกาํหนดชื+อเปน Untitled-x.ipynb ไวลวงหนา

4) หากตองการบันทึกไฟล ใหเลือกเมนู File > Save (หรือ Save As) แลวกําหนดชื+อใหมลงไป โดย

สวนขยายของไฟลตองเปน .ipynb เทานั้น เชน test.ipynb และเลือกจัดเก็บไวที่ใดก็ได ซึ่งตาม

การอางอิงในหนังสือเลมนี้ผูเขียนจะเก็บไวที่ C:\python

  วิธีที่ 2 เขาสู VS Code แลวเปดโฟลเดอรที่จะจัดเก็บไฟล Jupyter (ถายังไมมีโฟลเดอรดังกลาว

ตองสรางข้ึนมากอน)  เชนในหนงัสอืเลมนี ้ผูเขยีนจะเปดโฟลเดอรทีต่าํแหน�ง C:\python หลังจากนัน้ 

ใหทําดังนี้

1) ใหคลิกไอคอน New File

2) กําหนดชื+อไฟลตามตองการ โดยใหมีสวนขยายเปน .ipynb โดยไฟลจะถูกจัดเก็บลงในโฟลเดอร

ที่เรากําลังเปดในขณะนั้น

3) เมื+อเราคลกิเปดไฟลทีม่สีวนขยายเปน .ipynb 

สวน Editor ของ VS Code กจ็ะแสดงเครื+องมือ 

ในมุมมองของ Jupyter โดยอัตโนมัติ

การใชงานในครั้งตอไป เราอาจเปดไฟล .ipynb โดยตรง เชน เลือกเมนู File > Open File หรือจะเปด

โฟลเดอรทีจ่ดัเกบ็ไฟลเอาไว เชน เลอืกเมนู File > Open Folder แลวคอยเปดไฟล .ipynb ภายใน VS Code กไ็ด

1

2
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การใชเครื&องมือของ Jupyter
เราตองเปดไฟล ที่มีสวนขยายเปน .ipynb เครื+องมือของ Jupyter จึงจะปรากฏใหเห็น ดังที่ไดกลาวไป

ในหัวขอที่ผานมา สําหรับแนวทางการใชเครื+องมือที่สําคัญของ Jupyter มีดังนี้

การเขียนโคดและการรัน
เมื+อเราสรางหรือเปดไฟลของ Jupyter ตอไปก็สามารถเขียนโคดภาษาไพธอนลงในเซลลไดตามปกติ 

และหากตองการรัน ใหคลิกไอคอนหัวลูกศรท่ีขอบดานซายของเซลลนั้น แลวผลลัพธที่ได จะถูกนํามาแสดงที่

ดานลางของเซลล

นอกจากนี้ ยังมีทางเลือกอื+น ๆ  ในการรัน เชน กดคียบอรดปุม <Ctrl + Alt + Enter> เพื+อรันเซลลที่ถูก

เลือกในขณะนั้น (ตองคลิกที่เซลลใหอยูในสถานะ Active ซึ่งเสนขอบจะเปนสีฟา)

การเพิ่มและลบเซลล
หากเราตองการเพิ่มเซลลใหมเพื+อทดสอบโคดของเรื+องอื+น ๆ  ความจริงก็มีหลายทางเลือกที่ทําได แตวิธี

ที่น�าจะสะดวกที่สุดอาจเลือกอยางใดอยางหนึ่งดังนี้

  วิธีที่ 1 คลิกที่ปุม + Code ที่แถบทูลบารดานบน (ซายสุด) ซึ่งในกรณีนี้จะเปนการเพิ่มเซลลใหม

ตอจากเซลลที่ถูกเลือกในขณะนั้น หรือถาไมเลือกเซลลใดเลยก็จะเพิ่มตอจากเซลลแรก

  วิธีที่ 2 เมื+อตองการเพิม่เซลลทีต่าํแหน�งใด ใหเลื+อนเมาสมายงับรเิวณกึง่กลางหนาจอของตาํแหน�ง

นั้น เมื+อปรากฏปุม + Code ก็ใหคลิกปุมดังกลาว ซึ่งเซลลจะถูกเพิ่มที่นั่น
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หากเราตองการลบเซลลใดทิง้ไป ใหเลอืก (คลกิ) ทีเ่ซลลนัน้กอน เพื+อใหอยูในสถานะ Active ซึง่จะปรากฏ

แถบทูลบารที่มุมขวาบน แลวคลิกปุมไอคอนถังขยะ

การนําโคดของหนังสือมาใชงาน
เราไดทราบไปแลววา ภายในไฟล .ipynb ของ Jupyter อาจมีไดมากกวา 1 เซลล แตหากในไฟลเดยีวกนั

มจีาํนวนเซลลมากเกนิไป ก็อาจยุงยากตอการเลื+อนคนหาเมื+อตองการทดสอบในภายหลัง ดงันัน้ ในหนงัสอืเลมนี้ 

จึงจะแยกโคดของแตละบทใหอยูคนละไฟล เชน 

chapter2.ipynb สําหรับโคดตัวอยางทั้งหมดของบทที่ 2

chapter3.ipynb สําหรับโคดตัวอยางทั้งหมดของบทที่ 3

...
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ในแตละไฟลนั้น จะประกอบไปดวยเซลลยอย ๆ  สําหรับตัวอยางตาง ๆ  ที่มีในบทนั้น ๆ  ซึ่งจะเขียนกํากับ

เอาไวที่บรรทัดแรกของแตละเซลล และจะตรงกับที่ระบุไวในหนังสือ เชน

สําหรับโคดของหนังสือเลมนี้ ผูอานสามารถดาวนโหลดไดที่ http://www.developerthai.com ทั้งนี้

หากเราจะทดสอบการทํางาน ใหเขาสู VS Code แลวเปดโฟลเดอร python จากนั้นคอยคลิกเปดไฟลของบทที่

ตองการ ตอไปก็สามารถรันทดสอบตามหลักการที่ไดกลาวมาแลวทั้งหมด





ภ
 าษาไพธอนมอีงคประกอบและขอกําหนดทีส่าํคญัหลายอยางซึง่เราควรรูจกัในเบือ้งตน โดยสิง่ทีจ่ะกลาวถงึ 

 ในบทนี ้เชน การประกาศและกาํหนดคาตวัแปร การแสดงผล ขอมลูชนดิตวัเลขและสตริง รวมถงึการรบั 

ขอมูลทางคียบอรด ซึ่งสิ่งเหลานี้ลวนเปนพื้นฐานสําคัญของภาษาไพธอนที่เราตองใชงานกันไปตลอด

คียเวิรดของภาษา Python
คียเวิรด (Keyword) หรือ Reserved Words คือคําที่ถูกสงวนไวเปนคําสั่งสําหรับควบคุมการทํางาน  

ซึ่งเราไมสามารถนําคําเหลานี้ไปตั้งเปนชื+อตัวแปรหรือฟงกชันได โดยคียเวิรดทั้งหมดของไพธอนมีดังนี้

False await else import pass

None break except in raise

True class finally is return

and continue for lambda try

as def from nonlocal while

assert del global not with

async elif if or yield

พื้นฐานการเขียนโคด  
Python

2
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คาํวา True, False และ None ตองเขยีนขึน้ตนดวยตวัพมิพใหญ เพราะไมไดใชเพื+อเปนคาํส่ัง แตใชแทน

คาของขอมูล สวนคําอื+น ๆ  ตองเขียนเปนตัวพิมพเล็กทั้งหมด อยางไรก็ตาม ในอนาคตอาจมีการเพิ่มคียเวิรดเขา

มาใหมก็เปนได ซึ่งเราสามารถเขียนโคดเพื+อแสดงคียเวิรดทั้งหมดของเวอรชันที่ใชงานอยูในขณะนั้น เชน อาจ

เขียนคําสั่งลงในเซลลของ Jupyter ดังนี้

ตัวอยาง  2 -1  แสดงคียเวิรดทั้งหมดของภาษาไพธอน

import keyword
print(keyword.kwlist)

ถาเราไมแน�ใจวาคํานั้นเปนคียเวิรดของไพธอนหรือไม ก็สามารถตรวจสอบดวยคําสั่งดังนี้

keyword.iskeyword("คําที่จะตรวจสอบ")

ถาเปนคียเวิรดจะไดคําวา True กลับคืนมา แตถาไมใชจะไดคําวา False เชน
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ตัวอยาง  2 -2  การตรวจสอบวาเปนคียเวิรดของภาษาไพธอนหรือไม

import keyword

p = keyword.iskeyword("python")
print(p)

a = keyword.iskeyword("and")
print(a)

ลักษณะของตัวแปร
ตัวแปร (Variable) หมายถึงคําที่เราใชสําหรับอางอิงถึงขอมูลตาง ๆ  ทั้งการจัดเก็บและการนําขอมูลไป 

ใชงาน จะตองทําผานตัวแปร ซึ่งการตั้งชื+อตัวแปรในไพธอน มีขอกําหนดดังนี้

 ตองประกอบดวยตัว a - z หรือ A - Z หรือ Underscore (_) หรือตัวเลข 0 - 9 เทานั้น

 หามขึ้นตน (อักขระตัวแรก) ดวยตัวเลข แตตัวตอ ๆ  ไปสามารถใชเปนตัวเลขได

 หามมีชองวางหรืออักขระอื+นใดนอกเหนือจาก 2 ขอที่กลาวมา

 การเขียนดวยตัวพิมพเล็ก-ใหญตางกัน เชน abc, ABC, Abc ถือวาไมเหมือนกัน

 ตองไมซํ้ากับคียเวิรดของภาษาไพธอน

 ในภาษาไพธอน เรานิยมตั้งชื+อตัวแปรใหขึ้นตนดวยตัวพิมพเล็ก แตถาเปนการนําหลาย ๆ  คํามารวม

กันเปนชื+อตัวแปร ก็อาจใชรูปแบบอยางใดอยางหนึ่งคือ

 ๏ คั่นแตละคําดวยเครื+องหมาย Underscore (_) เชน max_value, is_first_time

 ๏ หรืออาจเขียนติดกัน โดยใหอักขระตัวแรกของแตละคําเปนตัวพิมพใหญ ยกเวนคําแรก เชน 

numProducts, isValidInput, numDaysOfMonth

 ตัวอยาง การตั้งชื+อตัวแปรที่ถูกตอง

 ๏ x

 ๏ value

 ๏ firstname

 ๏ pricePerUnit

 ๏ num1

 ๏ grand_total

 ๏ freeDiskSpace

 ๏ string2number

 ๏ v3_beta2

 ๏ core_i_7

 ๏ _x x_

 ๏ _x_
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 ลักษณะการตั้งชื+อตัวแปรที่ ไมถูกตอง

 ๏ price$ เพราะมีอักขระ $

 ๏ 3x เพราะเริ่มตนดวยตัวเลข

 ๏ class เพราะซํ้ากับคียเวิรด

 ๏ lucky number เพราะมีชองวาง

การกําหนดคาใหกับตัวแปร
ในภาษาไพธอน เราจะประกาศตัวแปรพรอมกบักาํหนดคาอยางใดอยางหนึง่ใหกบัมันทนัท ีโดยไมตองระบุ

ชนดิขอมลู และไมใชคยีเวริดอื+นใดเพื+อบงชีว้าเปนตวัแปรเหมอืนทีต่องทาํในภาษาอื+น ๆ  ซึง่รปูแบบโดยทัว่ไปของ

การสรางและกําหนดคาตัวแปรในภาษาไพธอนคือ

ชื+อตัวแปร = คาที่กําหนด

สาํหรับชื+อตวัแปร กใ็ชหลกัการตามท่ีไดกลาวไวในหัวขอทีแ่ลว สวนการกาํหนดคาใหกบัตวัแปร มีหลกัการ 

พื้นฐานทั่วไปคือ

 เราตองประกาศตัวแปรพรอมกําหนดคาอยางใดอยางหนึ่งใหมัน ในลักษณะดังนี้

x = คาที่กําหนด กําหนดคาใหกับมันทันทีที่ประกาศตัวแปร

y = คาที่กําหนด กําหนดคาใหกับมันทันทีที่ประกาศตัวแปร

a = x นําคาของตัวแปร x มากําหนดใหแกตัวแปร a (ตองมี x อยูกอนแลว)

b = x + y ตัวแปร b มีคาเทากับผลบวกของ x กับ y (ตองมี x และ y อยูกอนแลว)

 หากประกาศเพียงชื+อ หรือประกาศแลวไปกําหนดคาภายหลัง จะเกิดขอผิดพลาด

x ผิด เพราะกําหนดแคชื+อตัวแปร

a

a = คาที่กําหนด

ผิด เพราะตอนแรกระบุแคชื+อตัวแปร แมจะกําหนดคาในภายหลังก็ตาม

 ตัวแปรที่กําหนดคาใหกับมันเอาไวแลว สามารถเปลี่ยนแปลงคาในภายหลังได เชน

number = คาที ่1
number = คาที ่2
number = คาที ่3
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 ตามปกตนิัน้ คาทีก่าํหนดใหแกตวัแปร รวมทัง้เครื+องหมาย = ตองเขยีนในบรรทดัเดียวกบัตวัแปร แต

ถาจาํเปนตองเลื+อนคาทีจ่ะกาํหนดใหกบัมัน หรือเครื+องหมาย = ไปไวทีบ่รรทดัถดัไป ใหวางเครื+องหมาย 

Backslash (\) ตอทายตัวแปร หรือตอทายเครื+องหมาย = จากนั้นก็นําสวนที่เหลือไปเขียนที่บรรทัด

ถัดไปไดเลย เชน ลองเปรียบเทียบลักษณะการเขียนโคดที่ผิดและถูกตองดังตอไปนี้

 ๏ ลักษณะการเขียนที่ ผิด

number = 
 คาที่กําหนด

 ๏ ลักษณะการเขียนที่ ถูกตอง

number = \
 คาที่กําหนด

 นอกจากน้ี เราสามารถกําหนดคาใหแกตัวแปรหลายตัว ๆ  พรอมกัน โดยการเขียนคําสั่งในบรรทัด

เดียวกันดวยรูปแบบดังตอไปนี้

ตัวแปร1, ตัวแปร2, ตัวแปร3, ... = คาตัวแปร1, คาตัวแปร2, คาตัวแปร3, ...

การกําหนดขอมูลชนิดตัวเลข
การกําหนดขอมูลชนิดตัวเลขใหกับตัวแปร มีหลักการขั้นพื้นฐานคือ

 การกําหนดคาที่เปนขอมูลชนิดตัวเลขไมวาจะเปนจํานวนเต็มหรือทศนิยมก็ตาม สามารถระบุตัวเลข

ลงไปไดเลย เพราะตามปกติเราจะเขียนตัวเลขติดกันอยูแลว เชน

x = 123 จํานวนเต็ม

y = 456.789 เลขทศนิยม

a = -10 จํานวนเต็มติดลบ
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b = -20.25 เลขทศนิยมและติดลบ

c, d = 5, 15 c = 5 และ d = 15

 เนื+องจากภาษาไพธอนไมยดึตดิกบัชนิดขอมลู ดงันัน้ เราสามารถเปล่ียนคาของตวัแปรจากจาํนวนเต็ม

เปนทศนิยม หรือจากทศนิยมเปนจํานวนเต็ม โดยไมเกิดขอผิดพลาด เชน

x = 123

x = 4.56

เดิมเปนจํานวนเต็ม แลวเปลี่ยนเปนเลขทศนิยม

y = 7.11

y = 101

เดิมเปนเลขทศนิยม แลวเปลี่ยนเปนจํานวนเต็ม

 การเขียนตัวเลขนั้น เรา ไม สามารถใชเครื+องหมาย , เพื+อคั่นหลักพันได แตในภาษาไพธอน อนุญาต

ใหเราใสเครื+องหมาย Underscore (_) แทรกลงไประหวางตัวเลขเพื+อใหอานงายขึ้น โดยสามารถนํา

คานั้นไปคํานวณไดตามปกติ ซึ่งขอกําหนดที่สําคัญคือ

 ๏ สามารถเขียน _ แทรกไวระหวางตัวเลขไดทั้งสวนจํานวนเต็มและทศนิยม

 ๏ ไมจําเปนตองใชคั่นหลักพัน แตคั่นระหวางตัวเลขที่หลักใด ๆ  ก็ได

 ๏ หามเขียนเครื+องหมาย _ ตอเนื+องกันตั้งแต 2 อันขึ้นไป

 ๏ หามใชเปนตัวขึ้นตนและตัวสุดทาย ทั้งสวนจํานวนเต็มและทศนิยม

 ๏ สามารถนําตัวเลขนั้นไปคํานวณไดตามปกติ

 ๏ ถาเราแสดงตัวเลขนั้นออกไป เชน ใชฟงกชัน print( ) จะไมมีเครื+องหมาย _ ปรากฏใหเห็น

x = 1,234 ผิด (ใชเครื+องหมาย , คั่นหลักพันไมได)

a = 1_234_567

print(a)

print(a + 1)

ถูก เขียนแบบนี้ได

1234567

1234568

b = 1_2_3_4 ถูก เขียนแบบนี้ได (ไมจําเปนตองใชคั่นหลักพัน)

c = 1__2___3 ผิด (หามเขียน _ ตอเนื+องกันตั้งแต 2 อันขึ้นไป)

d = _1_2_3 ผิด (หามใช _ เปนตัวขึ้นตน)

e = 1_2_3_ ผิด (หามใช _ เปนตัวสุดทาย)
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f = 123_456.78_9_0

print(f)

ถูก เขียนแบบนี้ได

123456.789

g = 12._3_4_5   ผิด (เพราะสวนทศนิยมขึ้นตนดวย _)

h = 123.456_ ผิด (เพราะสวนทศนิยมลงทายดวย _)

สําหรับรายละเอียดเพิ่มเติมของขอมูลชนิดตัวเลข จะกลาวถึงอีกครั้งในบทที่ 3

การกําหนดขอมูลชนิดสตริง 
สตริง (String) เปนการนําอักขระแตละตัวมาวางเรียงตอกันใหกลายเปนขอความ ซึ่งเราตองกําหนดจุด

เริ่มตนและสิ้นสุดของมันดวยเครื+องหมายคําพูด (Quotes) แบบใดแบบหนึ่งคือ

 Single Quotes (' ')

 Double Quotes (" ") 

 Single Triple Quotes (''' ''') หรือ Double Triple Quotes (""" """) หรือเรียกรวม ๆ  วา Triple 

Quotes

title = "Python Programming"
birthday = 'Happy Birthday'
christmas = '''Merry Christmas'''
new_year = """สวัสดี ปใหม"""
firstname, lastname = 'Tom', "Jerry"

สตริงที่กําหนดดวยเครื+องหมาย " " หรือ ' ' อันเดียวกัน (ไมรวม Triple Quotes) ตองเขียนในบรรทัด

เดียวกันใหครบทั้งหมด หากแยกสตริงที่อยูในเครื+องหมาย " " หรือ ' ' อันเดียวกัน ไปขึ้นบรรทัดใหม จะเกิด

ขอผิดพลาด เชน กรณีตอไปนี้

a = "Python 

Programming"

ผิด เพราะแยกสตริงที่อยูในเครื+องหมาย " " อันเดียวกัน ไปขึ้นบรรทัดใหม

b = 'ไพธอนไมใชงู

แตเปนภาษาคอมพิวเตอร'

ผิด เพราะแยกสตริงที่อยูในเครื+องหมาย ' ' อันเดียวกัน ไปขึ้นบรรทัดใหม

อยางไรก็ตาม หากเปนสตริงที่ยาวมาก จนไมสามารถเขียนใหครบในบรรทัดเดียวกันได ก็มีทางเลือกให

เราสามารถแยกสตริงไปเขียนไวคนละบรรทัดได โดยใชวิธีใดวิธีหนึ่งคือ
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 วิธีที่ 1 หากกําหนดสตริงดวยเครื+องหมาย " " หรือ ' ' ใหแทรกเครื+องหมาย Backslash (\) ตรง

จุดที่จะแยกสตริงไปขึ้นบรรทัดใหม เชน

a = "Python \

Programming"

ถูก หลังจากแทรกเครื+องหมาย \ สามารถแยกสตริงอยูในเครื+องหมาย " " อัน

เดียวกัน ไปขึ้นบรรทัดใหมได 

b = 'ไพธอนไมใชงู \

แตเปนภาษาคอมพิวเตอร'

ถูก เพราะแทรกเครื+องหมาย \ ตรงจุดที่จะขึ้นบรรทัดใหมแลว

 วิธีที่ 2 หากกําหนดดวย Triple Quotes ไมวาจะเปน """ """ หรือ ''' ''' ก็ตาม สามารถแยก

สตริงไปขึ้นบรรทัดใหมไดเลย โดยไมจําเปนตองแทรกเครื+องหมาย \ เชน

a = """Python 

Programming"""

ถูก สามารถแยกสตริงอยูในเครื+องหมาย """ """ อันเดียวกัน ไปขึ้นบรรทัด

ใหมไดเลย

b = '''ไพธอนไมใชงู 

แตเปนภาษาคอมพวิเตอร'''

ถูก การใชเครื+องหมาย ''' ''' สามารถแยกสตริงไปขึ้นบรรทัดใหมไดเลย

การแทรกเครื+องหมาย \ ในสตริงดังที่กลาวมา เปนเพียงการแยกบรรทัดในขั้นตอนการเขียนโคดเทานั้น 

ซึ่งเมื+อนําสตริงไปใชงานอื+นตอไป เครื+องหมาย \ จะไมรวมอยูในสตริง จึงสามารถใชงานไดเชนเดียวกับสตริง

ทั่วไป แตก็มีปญหาอยางหน่ึงที่เราควรคํานึงถึง น่ันก็คือ หากเราแยกสตริงไปขึ้นบรรทัดใหม ไมวาจะเปนการ

แทรกเครื+องหมาย \ ไวในสตรงิ หรอืการใช Triple Quotes กต็าม หากเยือ้งสตริงเขาไป เมื+อเราแสดงผล จะเกิด 

ชองวางระหวางสตริงตามระยะที่เยื้องเขาไป เชน

ตัวอยาง  2 -3  ระยะเยื้องที่เกิดจากการแทรกเครื+องหมาย \

count = \
'One, \
    Two, \
     Three, \
        Four'

print(count)

ถาเราไมตองการใหมีชองวางดังที่กลาวมา อาจใชวิธีการแบงสตริงออกเปนสวนยอย ๆ  ใหอยูใน

เครื+องหมาย " " หรือ ' ' คนละอนั แลวคอยนาํสตรงิเหลานัน้มาเชื+อมตอเขาดวยกนั ดงัทีจ่ะกลาวถงึในหวัขอตอไป
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สําหรับการกําหนดสตริงดวยเครื+องหมาย " " หรือ ' ' นั้น ตามปกติเราจะเลือกใชอะไรก็ได หรือบางครั้ง

อาจใชรวมกัน เชน ถาในสตริงนั้นมีเครื+องหมาย " เปนสวนหนึ่งของมันดวย เราก็ครอบสตริงทั้งหมด (ชั้นนอก) 

ดวย ' ' หรือในทางตรงขาม ถาในสตริงนั้นมีเครื+องหมาย ' เปนสวนหนึ่งของมันดวย เราก็ครอบสตริงทั้งหมด

ดวย " " เชน ลองเปรียบเทียบกรณีตอไปนี้

msg = 'Let's go' ผิด เพราะใชเครื+องหมาย ' ซอนกัน

msg = "Let's go"        ถูก  

str = "She said "Hello"" ผิด เพราะใชเครื+องหมาย " ซอนกัน

str = 'She said "Hello"' ถูก  

อยางไรก็ตาม สําหรับปญหาการเขียนเครื+องหมาย " หรือ ' ไวในสตริง เราอาจแกไขโดยการวาง

เครื+องหมาย Backslash (\) ไวหนา " หรือ ' ที่เปนสวนหนึ่งของสตริง ซึ่งวิธีนี้เราสามารถกําหนดสตริงดวย " 

" หรือ ' ' เพียงอยางใดอยางหนึ่ง โดยไมตองใชสลับกันก็ได เชน

msg = 'Let\'s go' หากแสดงผลจะกลายเปน  Let's go

str = "She said \"Hello\"" หากแสดงผลจะกลายเปน  She said "Hello"

สําหรับรายละเอียดเกี่ยวกับขอมูลชนิดสตริงยังมีอีกมาก ซึ่งเราจะไดเรียนรูเพิ่มเติมทั้งในบทนี้และบท

ตอ ๆ  ไป

การแสดงผลดวยฟงกชัน print( )
เมื+อเราตองการแสดงขอความออกไปท่ีหนาจอ จะกาํหนดดวยฟงกชนั print( ) พรอมระบขุอมลูทีต่องการ

แสดงไวในวงเล็บ ซึ่งที่ผานมานั้น แมเราจะใชฟงกชันนี้มาบางแลว แตยังมีรายละเอียดอีกหลายอยางที่ควรรู

เพิ่มเติมดังตอไปนี้

การใชฟงกชัน print( ) แบบพื้นฐาน
รูปแบบพื้นฐานที่สุดของฟงกชัน print( ) มีลักษณะดังนี้

 print(ขอมูล)
หรือ print(ขอมูล1, ขอมูล2, ขอมูล3, ...)
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 สาํหรับขอมลูทีจ่ะแสดงผล หากเปนขอความ (สตริง) ใหเขยีนไวในเครื+องหมายคาํพดู (Quotes) แบบใด 

แบบหนึ่งดังที่กลาวมาแลว

 หากเปนตัวเลข สามารถเขียนลงไปในวงเล็บไดโดยตรง

 หากจะแสดงคาของตัวแปร ก็ระบุชื+อตัวแปรนั้นลงในวงเล็บไดเลย

 หากเรากําหนดแค print( ) โดยไมระบุขอมูลที่จะแสดง จะเปนการแทรกบรรทัดวาง และถาตองการ

แทรกหลายบรรทัด ก็ระบุ print( ) ตามจํานวนบรรทัดที่ตองการ

ตัวอยาง  2 -4  การใชคําสั่ง print( ) เพื+อแสดงขอมูลชนิดตาง ๆ

print('Hello')
print('สวัสด'ี)
print(123)
print(456.789)
print()   

language = 'Python'
version = 4.0
print(language)
print(version)

 สาํหรบัรูปแบบ print(ขอมลู1, ขอมลู2, ขอมลู3, ...) เปนการแสดงขอมลูมากกวา 1 อยางแบบตอเนื+อง 

ในบรรทัดเดียวกัน โดยใชฟงกชัน print( ) เพียงครั้งเดียว ซึ่งขอมูลเหลานั้นอาจเปนสตริง ตัวเลข 

หรือคาจากตัวแปรก็ได และขอมูลแตละคาจะถูกเวนชองวางใหโดยอัตโนมัติ เชน

ตัวอยาง  2 -5  การแสดงขอมูลหลายคาในคําสั่ง print( ) เดียวกัน

print('Python', 'Programming', 'for', 'Beginner')

a = 'หนึ่ง,'
b = 'สอง,'
c = 'สาม,'
print(a, b, c, 'สี'่)

name = 'Guido van Rossum'
year = 1994
print(name, 
 'สรางภาษาไพธอนในป ค.ศ.', 
 year)
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การใชฟงกชัน print( ) ที่ซับซอนข้ึน
เราสามารถกําหนดลักษณะการแสดงผลเพิ่มเติมใหกับฟงกชัน print( ) โดยใชรูปแบบอยางใดอยางหนึ่ง

ดังนี้

print(ขอมูล1, ขอมูล2, ขอมูล3, ..., sep=...)
print(ขอมูล1, ขอมูล2, ขอมูล3, ..., end=...)
print(ขอมูล1, ขอมูล2, ขอมูล3, ..., sep=..., end=...)

 สําหรับขอมูล 1, 2, 3, ... ก็เหมือนกับรูปแบบในหัวขอที่แลว คือจะมีจํานวนเทาไหรก็ได

 sep และ end เปนการระบุออปชนัเพิม่เตมิใหกบัฟงกชนั โดยลกัษณะเชนนีใ้นภาษาไพธอนจะเรียกวา 

Keyword Argument (หรือเรียกสั้น ๆ  วา คียเวิรด) แตเปนคนละกรณีกับ Keyword หรือ Reserved 

Word ที่เปนคําสงวนของไพธอน ซึ่งเราจะไดศึกษารายละเอียดเรื+องนี้ในบทที่ 10

 sep (มาจาก separator) คอืสิง่ทีจ่ะใชคัน่ระหวางขอมลูแตละอนั โดยคาทีก่าํหนดใหแก sep ตองเปน 

สตริงเทานั้น (อยูในเครื+องหมายคําพูดแบบใดแบบหนึ่ง) ซึ่งตามปกติ (ไมระบุ sep) จะเปนชองวาง 

1 ชอง

 end คือสิ่งที่จะเขียนตอทายสตริง และตองกําหนดในแบบสตริงเชนเดียวกับ sep โดยตามปกติ (ถา

ไมระบ ุend) จะเปน '\n' ซ่ึงเปนสญัลกัษณสาํหรับการขึน้บรรทดัใหม (รายละเอียดอยูในหวัขอถดัไป)  

แตถาตองการใหฟงกชัน print( ) ถัดไป แสดงผลในบรรทัดเดียวกับฟงกชัน print( ) ปจจุบัน ให

กําหนดคาเปน end='' 

 อาจกําหนด sep และ end เพียงอยางใดอยางหนึ่ง หรือกําหนดทั้งคู หรือไมมีเลยก็ได

ตัวอยาง  2 -6  การใชออปชัน sep และ end ของคําสั่ง print( )

a = 'One'
b = 'Two'
c = 'Three'
d = 'Four'
print(a, b, c, d, sep=', ')

a = 'www'
b = 'developerthai'
c = 'com'
print(a, b, c, sep='.')
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d = 1
m = 'กรกฎาคม'
y = 2565
print('ออกเดินทางในวันที:่ ', end='')
print(d, m, y, sep=' ')

h = 12
m = 34
print('เวลา: ', end='')
print(h, m, sep=':')

ลักษณะพื้นฐานของสตริงที่ควรรูเพิ่มเติม
เนื+องจากสตริง เปนชนิดขอมลูพืน้ฐานสําคัญทีเ่ราตองนาํไปใชกนัอยูตลอด ดงันัน้จงึมรีายละเอียดปลกียอย 

คอนขางมาก โดยในหัวขอนี้ จะกลาวถึงลักษณะพื้นฐานบางอยางเกี่ยวกับสตริงที่เราควรรูจักเพิ่มเติม ซึ่งตองใช

รวมกับเนื้อหาของเรื+องตอ ๆ  ไป สวนรูปแบบการใชงานอื+น ๆ  จะกลาวถึงอีกครั้งในบทที่ 8

การเชื&อมตอสตริง
การเชื+อมตอสตรงิ (String Concatenation) เปนการนาํสตริงยอย ๆ  มารวมเขาดวยกนั โดยใชเครื+องหมาย 

+ เพื+อใหกลายเปนสตริงอันเดียวกัน รวมถึงการนําคาจากตัวแปรมารวมกับสตริงอีกดวย เชน

ตัวอยาง  2 -7  การเชื+อมตอสตริงดวยเครื+องหมาย +

str1 = 'ขอเชิญหมายเลข ' + ' สามสิบ ' + ' ที่ชองบริการ' + ' หา ' + 'คะ'
print(str1)

name = 'Guido van Rossum'
str2 = 'ผูสรางภาษาไพธอนคือ ' + name + ' เมื+อป 1994'
print(str2)

name = "Malee"
country = "Thailand"
print("My name is " + name + 
  " from " + country)

อยางไรก็ตาม ในภาษาไพธอนนั้น ไมสามารถใชเครื+องหมาย + เพื+อเชื+อมตอระหวางสตริงกับตัวเลข

โดยตรงได เชน กรณีตอไปนี้ จะเกิดขอผิดพลาดทั้งหมด




